Vero 4K+ Harmony + Keymap editor problem

Hi Everyone!

I tried to search for that problem but did not find quite the same scenario I have so that is why I ask for your help.

The situation is the following: I have a Vero 4K+ with a Harmony companion+hub added to the Vero via bluetooth; in the Harmony app the Vero is added to my setup as Microsoft media player (Microsoft KODI).

What I would like to achieve is to use the number key zero with virtual keyboards in Kodi as number pad zero. In MyHarmony the zero key is mapped to 0 both long and short press. I have Keymap editor installed in Kodi and I modified Virtual keyboard 0 to the button on my remote under both ‘Global’ and ‘Navigaton’. In the gen.xml it is there with the correct key id mapped to ‘number0’. Despite of that whn I push the button when a virtual keyboard is open first one space is entered and if I keep pressing it, various symbols appear. If I press it for some time I get to the number zero.

Could anyone help me please what do I miss here? I checked the tutorial here but my setup seems to be the same/very similar, the only difference is that instead of I have for number0.

Any help is really appreciated! Thank you in advance!

Are you trying to recreate the SMS function in keymap editor so you don’t have to manually edit (you can’t) or did you manually edit and then have an issue you are trying to fix? Keymap editor can be great for simple things it supports but unfortunately once you throw it some code outside of what it makes it tends to make a mess of things and destroys keymaps including replacing good working code with incorrect code if it doesn’t just remove it outright.

To understand what exactly is currently being used I really need to see what is in your keymap. You can ssh and enter the following to generate a url that you can post in this thread…

paste-log ~/.kodi/userdata/keymaps/gen.xml

Thank you for your reply darwindesign!

I did not add any command to the gen.xml manually. I only edited it through the plugin in Kodi. What I did today was to make it easier to read so it is not one long line.

I hope I made the right log, here it is: https://paste.osmc.tv/uqotarokir

Thank you for the help!

This is rather odd. I don’t see anything problematic in the keymap so we are going to have to dig a bit deeper to figure out what is going on. Can you restart twice, turn on debug logs, bring up a virtual keyboard and press 0 enough times to reproduce this odd behavior then upload that Kodi log.

https://osmc.tv/wiki/general/how-to-submit-a-useful-support-request/

Thank you for looking into it.

I was about the perform what you advised when I thought to try one more thing. In Keymap editor I cleared the mapppings for key zero in from very virtual keyboard, saved it and tried the button. When I had only a virtual numpad in Kodi the zero button worked as intended. When I had a full virtual keyboard onscreen and I pressed the 0 on the remote it did not give me the symbols I mentioned but the letter ‘ö’.

What I did not write in my first comment (sorry for that) is that I am from Hungary so I had Hungarian keyboard layout set up in Kodi under ‘System>Input’ and both in ‘Interface>Regional’. As the letter ‘ö’ is at the same place on the Hungarian layout as 0 in US/UK layout I tried to change the layout to English under ‘Regional’. Tried again with a virtual keyboard but I got ‘ö’ again for button 0. Then went to ‘Settings>System>Input’, changed keyborad from Hungarian to English(UK) et voilá, button zero gives 0 on the virtual keyboard.

So right now it is solved but of course when I will pulg in my keyboard it will not be set up correctly and will have to change keyboard back to Hungarian (I guess). What I thought about is mapping button zero to ‘`’ in MyHarmony, change the keyboard back to Hungarian and check if it works that way (as that key is at the same place on the English layout as 0 on the Hungarian). But maybe it would mess up the virtual numpad setup (?)

That should not interfere with the virtual number pad if you make sure you get the mappings correct. It is also the easiest way to get around this language issue in Kodi. We actually worked on this issue for awhile with the OSMC remote and nobody here could find a way to get around what appears to be a Kodi limitation to how they are handling different keyboard languages. We opted to sidestep the issue by avoiding dead keys and keys that change layout in any of the languages we ship with. The key your using with the Hungarian layout is causing issues because it is not able to be identified correctly by Kodi (on the remote side, unrelated to text input) and so it actually gets shoved in a catch-all key id and trying to map that leads to unpredictable outcome. The only issue with your plan that I see is that I wouldn’t expect that Microsoft media player configuration in the Harmony software to have the left quote as an option to map there. You would probably need to program that button on your remote to some available key your not planning on using. In Kodi you would then turn on debug logging, press that key and then check your log to make sure it is being picked up correctly. If it is then you can map it globally to the “Number0” action, and then just map that key to anywhere in the sms stuff your adding instead of zero.

Ok, thank you very much again for checking my comment and thank you for your recommendations. I will look into it but right now the button works as I would like it to so all is good :wink:

Thank you again!