Vero 4K+ & HDR10 = SDR according to HDfury


When playing HDR10 content (Blu-ray folder, mkv, m2ts) on my Vero 4K+ my HDfury Integral 2 reports SDR. My TV (Sony XBR-75Z9F) reports HDR10 but the color seems a little muted/washed out vs my other sources (Apple TV 4K, Sony Blu-ray player, Windows 10 PC) which are reported as HDR by both my HDfury and TV. I tried forcing 4:2:2 and full range but that didn’t change anything (other than my HDfury reporting 422 instead of 444).



Can you post some logs?



This is right after enabling debug logging, rebooting and immediately playing an HDR10 movie.

According to the logs, we are ouputting the correct format. My Vertex sometimes gets confused about what signal is being sent.

  • do you get the same colours when not using the Intregral?
  • is the Integral reporting BT2020nc?
  • can you copy and post the HDR Infoframe from the Integral?

I haven’t tried without the fury yet but I have two of them and they both have the same output and they only show the wrong output with the Vero.

TX1: 4k23.975 422 BT2020 12b SDR 297MHz				            AUD: HBR bitstream
HDR: RX-SMPTE ST 2084 Lum 4000/0.005 maxCLL/FALL 1059/385		MTR: DCI-P3 D65

Only difference I’ve seen on my furys between my other devices and the Vero is the TX1 line. I get HDR for my other devices but the furys show SDR for the Vero.

The default for my TV’s video range and color space settings is auto. I’m going to experiment with those next to see if anything changes.

Just checked on my Apple TV 4K again and the fury also shows different HDR numbers for lum and maxCLL/FALL:

TX0: 4k23.975 422 BT2020 12b HDR 297MHz 2.2			            AUD: L-PCM 48kHz 7.1ch 24bit
HDR: RX-SMPTE ST 2084 Lum 3999/0.005 maxCLL/FALL 4000/1000		MTR: BT2020 D65

It also shows (HDCP) 2.2 whereas no HDCP value is given with the Vero.

Tried different HDMI cable to the Vero?

Same cable I used with my Windows PC (the Vero is replacing my HTPC) which didn’t show any color or hdfury oddities. I’m guessing it has to do with the differing HDR numbers.

The video you are playing appears to be in Dolby Vision. The ATV will be decoding that and sending a modified version of the stream to your TV which supports DV. And it will be modifying the metadata to suit.

The Vero can only play the base layer HDR10 and pass through the original HDR10 metadata. What you see on the Integral should be the same as what mediainfo reports.

As to why it says SDR, this means there’s a mis-match between the AVI InfoFrame and what HDFury call the HDR InfoFrame. The HDR InfoFrame appears correct (the second line of what you posted).

Can you make a short clip of that video and post it somewhere so we can see where that mis-match is coming from?

I guess that particular movie is a bad example since it is P7 DV which the ATV doesn’t support and is why the ATV is falling back on (and playing) the HDR10 layer only as confirmed by both my TV and the HDfury. If I play back an HDR10 only movie (something that was never even released in DV) the results are the same. I’m not sure how I can get you a clip. How do I edit/trim a 50+GB blu-ray movie?

dd if="/mnt/downloads/movies/Ghostbusters Afterlife (2021)/Ghostbusters.Afterlife.2021.2160p.BluRay.HEVC.TrueHD.7.1.Atmos-MT.m2ts" of=~/GBA.m2ts conv=fsync bs=1M count=100

That should give us the first 100MB of it. Upload to a google drive/dropbox or other place where we can grab it.

I thought ATV 4k does do Dolby Vision?

1 Like

Only profile 5. Profile 7 is for blu-ray players only (and the oppo clones/ripoffs) but any HDR10/10+ device should be able to play the base layer (the HDR10) and that’s what the ATV does (with Infuse) as well as my HTPC before I replaced it with the Vero. Profile 8 is what the iPhone uses to record DV and the ATV doesn’t even play that.

Here’s the clip:

1 Like

Here’s a clip from a movie without DV:

HDfury shows this when playing on Vero:

TX1: 4k23.975 422 BT2020 12b SDR 297MHz				            AUD: HBR bitstream
HDR: RX-SMPTE ST 2084 Lum 1000/0.005 maxCLL/FALL 992/226		MTR: DCI-P3 D65

And this when playing on the ATV:

TX0: 4k23.975 422 BT2020 12b HDR 297MHz 2.2			            AUD: L-PCM 48kHz 5.1ch 24bit
HDR: RX-SMPTE ST 2084 Lum 3999/0.005 maxCLL/FALL 4000/1000		MTR: BT2020 D65

That’s useful to know. It looks like ATV isn’t giving your TV a chance to optimise playback on the static metadata. And why on earth would Apple not support the format from its own devices?? iPhone HDR footage is HLG in a DV wrapper so ATV should at least play the HLG base layer.

I’ve never come across any HLG content so I don’t know for sure but even though Apple specifies support for HLG I’ve seen reports that HLG playback on ATV doesn’t work either.

What makes you say that?

These values are made up by the ATV. It seems the device must be changing the signal rather than just passing it through then making a guess as to how a display will react to those values. Seems strange from where I’m sitting.

I’ve always used my ATV for mostly streaming services (SDR and DV only) and the only local content I’ve used it for is DV (profile 5) so I didn’t notice this before. For local HDR10 content I always used my PC (now Vero). Anyway, Apple being Apple you have to use a third party app to play back any local content and everyone uses Infuse for that and apparently the Infuse devs aren’t able to send the actual values so the ATV just uses the same fixed ones.

I see. So it’s infuse that’s the issue.

I wonder what you see if you capture the HDR infoframe from Vero on the Integral and inject it into the stream from the ATV. You should then get an apples to apples comparison of the ATV output with the Vero output.

I’m still working on the SDR/HDR issue. Out of interest, if you set the HDR output (in settings->Player) to Passthrough, does the Integral show HDR and does the picture look better?