Vero 4K How to start again

Arrggghhh, Finally had the system up and running beautifully then the Teenage son decides to play with it while I was out. He has tried to add a Kodi Build and crashed the system. Please could you advice how I can start fresh again. So frustrated with him

https://osmc.tv/wiki/vero-4k/reinstalling-osmc/

Hello fzinken, Thank you for your reply. I followed the link but when you get to the section asking for what you want to put the download onto. You cannot select USB or anything else. It is stuck on SD Card. Tried numerous times but still the same

regards Paul

The question is not asking what you want the download to be put on but what you want to install OSMC onto. For the Vero4k the only option is the internal emmc so therefore nothing can be choosen there. You choose your SD Card or USB as a target for the download on the next screen.

If all you need to do is just reset Kodi to factory, just ssh into the device and issue the following three commands

sudo systemctl mediacenter stop
rm -rf .Kodi
sudo systemctl mediacenter start

@bunyip73 or even easier MyOSMC - Updates - Manual Controls - Reset Kodi on next reboot

1 Like

Just tried the MyOSMC - Updates- Manual Controls - Reset Kodi on next reboot. Into Power and selected reboot. System came back on and still running the Build that my son had attempted to put on. The other step about ssh into the device. What is meant by this and how do I try it. Sorry if its a basic question. This operating system totally new to me. Thanks again for all assistance and advice.

Well it will execute the same steps to what MyOSMC would have done. But really strange why the build survived that (must have been a really sticky one. You still can try the steps described by @ActionA. Just access the Vero by ssh (how is explained below) and then copy/paste the 3 commands into the command line.
Details regarding how to access the command line interface can be found here on our Wiki: https://osmc.tv/wiki/general/accessing-the-command-line/

Thanks again fzinken, I retried the download way but could only get it to work with Decembers download. Got that to install and then had to try several times to get January’s update to work. Kept coming up with an error. All appears good now. Just need to start again installing stuff. Thank you all for your time, patience and assistance once again. It is greatly appreciated.

Thats strange. What was the error? Could it be network connection issues?

Error said something along the lines of report it on the forum or something. You are probably correct in thinking it may be network connection related as we are well known for poor internet in Australia.

He has a teenage son - who knows what state it’s in?

2 Likes

Ha Ha , your hearing me…