Vero 4k+ Just died: power supply?

Not sure what happened but it seems to have completely died. Started yesterday when I noticed it wasn’t running a USB external hard drive properly. The drive was just clicking and not spinning. Eventually I got it to connect and it eventually after a very long time read the contents but after 5 minutes of eventually starting to play something it froze and re-booted. It did come back to life after about 5 minutes but then switched off although the red glow of the optical output was there.

I tried it with nothing connected and after unplugging various times it did come up to the welcome screen then immediately died. Now nothing, not even the red glow of optical. I tried the USB hard drive in a PC and it is fine.

I realise I might have overloaded it with the hard drive (can the USB ports run a USB hard drive OK?) but it has been working fine for over a month like that with probably 100+ hours.

Could the power supply be toast or more likely the unit? I understand you can power by USB ports but needs the correct lead?

Are there any other tests or resets I can try with it?

You shouldn’t power a hard drive from the device directly and instead need to use the drive’s PSU or a powered USB hub.

A bog standard USB-A cable can be used on either port to try and power the device. You’d want to definitely disconnect the drive when doing this

If you have another 5V, 2A power supply you could also try that (take a photo and post here first).


Thanks for the very quick reply. I will have a cable hunt tomorrow and see if I can find a USB A to A or a PSU. It looks as if 5v 2A is what is needed.

If it comes back to life I will make sure I use a hub in future, although to be fair it had been coping fine.

Really don’t recommend just having the drive directly connected.

You can’t damage the device by doing this but you could lose data / cause filesystem corruption. The USB2 spec means we can only push 0.5a per port. That’s pretty much a no go for any 3.5” drive to work reliably

If you open a support ticket or let me know the order number here we can put another power supply in tomorrow’s post. You’re in the U.K. so would have it Friday.


It was the power supply. Got hold of another identical output one and it came fully back to life.

1 Like