Vero 4k+ LAN slow bitrate

#1

Hello,
after prolonged use with smaller bitrates, I have now switched to larger and have found that my speed is insufficient.
I have my Vero 4k + connected to a Fritzbox 7590th
The data storage is Synology DiskStation 418j.
After several searches in the forum and with my poor English knowledge I tried different things.
I also did the iperf test.

root@DiskStation418j:~# iperf -c 192.168.178.2
------------------------------------------------------------
Client connecting to 192.168.178.2, TCP port 5001
TCP window size: 85.0 KByte (default)
------------------------------------------------------------
[  3] local 192.168.178.66 port 55682 connected with 192.168.178.2 port 5001
[ ID] Interval       Transfer     Bandwidth
[  3]  0.0-10.0 sec  1.07 GBytes   919 Mbits/sec

192.168.178.66 is my Synology DiskStation
192.168.178.2 is my PC

then I tested my vero 4k +

osmc@osmc:~$ iperf -c 192.168.178.66
------------------------------------------------------------
Client connecting to 192.168.178.66, TCP port 5001
TCP window size: 85.0 KByte (default)
------------------------------------------------------------
[  3] local 192.168.178.7 port 45247 connected with 192.168.178.66 port 5001
[ ID] Interval       Transfer     Bandwidth
[  3]  0.0-10.0 sec  29.2 MBytes  24.5 Mbits/sec
osmc@osmc:~$ iperf -R -c 192.168.178.66
------------------------------------------------------------
Client connecting to 192.168.178.66, TCP port 5001
TCP window size: 85.0 KByte (default)
------------------------------------------------------------
[  3] local 192.168.178.7 port 45250 connected with 192.168.178.66 port 5001
[ ID] Interval       Transfer     Bandwidth
[  3]  0.0-10.0 sec  38.9 MBytes  32.6 Mbits/sec

192.168.178.7 is my Vero 4k +

my vero 4k + is connected with Lan cable.
My advancedsettings.xml is with

<cache>
    <buffermode>1</buffermode>
    <memorysize>524880000</memorysize>
    <readfactor>5.0</readfactor>
</cache>

adjusted.

My 1080p Movie with 60 FPS and a bitrate 31469 kBit/s is play fine
my 1440p Movie with 25 FPS and a bitrate 60019 kBit/s don´t play (buffering too long)

I use the NFS Mount.

my 2160p Movie with 65000 kBit/s play fine with my old USB 2.0 Stick.
My order number was #19637

Where is the problem here?

0 Likes

#2

First, I would suggest that you use iperf3, instead of iperf.

You have provided us with some good information but for completeness please also provide:

  1. Full logs on the Vero4K grab-logs -A
  2. iperf3 statistics from the PC to the Synology DS and reverse (-R).
  3. On both the Synology DS and the Vero4K, run the command ethtool eth0 and provide the output.
0 Likes

#3

Contact support@osmc.tv and we can resolve this for you.

Sam

0 Likes

#5

iperf3 does not run on the ds418j with realtek 1293 processor. because docker I can not use synonymous. The operating system is not a complete Linux. That’s how I read. I hope you understand the translation. The rest I will test again tonight. I wrote the support with a different email address. … n8 @ googlem …

0 Likes

#6

try here:

http://www.jadahl.com/iperf-arp-scan/DSM_6.2/

as i read this:

https://www.synology.com/en-global/knowledgebase/DSM/tutorial/Compatibility_Peripherals/What_kind_of_CPU_does_my_NAS_have

System Model CPU Model Package Arch

|DS418j|Realtek RTD1293| rtd1296|

it seems to me that you should install this package on DS418J without docker

had this installed myself on DS411+ii (diff model) but also without docker

1 Like

#8

I have rtd1293 in my ds418j I have read this before.
I will try it later.

0 Likes

#12

Could this be a duplex mismatch?
As @dillthedog noted – the issue seems to occur in both directions. We’ve never experienced this before and only the TX direction would be expected to be impacted if there was a hardware issue

Sam

0 Likes

#13

I start again to explain what configuration I have. This is just an excerpt with a few devices.
Raspberry Pi3 only works with libreelec.

FritzBox 7590 > Netgear GS108EV3 -> Vero 4k+
                                 -> Synology Diskstation 418j
                                 -> Raspberry Pi3 
                                 -> Netgear GS108EV2 -> PC
                                                     -> Raspberry Pi3
              -> Raspberry Pi3

My Netgear ist set to Auto. The port speed is set automatically after the switch determines the speed using autonegotiation with the linked device. This is the default setting.
I have

FritzBox is set to LAN 1 with 1 Gbit/s

The Netgear is set to standard settings.

My Synology is set to 1000 MBit/s, Vollduplex, MTU 1500
I have already replaced the Netgear GS108EV3. I had the Netgear GS108EV2 on it before. I also replaced the cables

osmc@osmc:~$ ethtool eth0
Settings for eth0:
        Supported ports: [ TP MII ]
        Supported link modes:   10baseT/Half 10baseT/Full
                                100baseT/Half 100baseT/Full
                                1000baseT/Half 1000baseT/Full
        Supported pause frame use: Symmetric Receive-only
        Supports auto-negotiation: Yes
        Advertised link modes:  10baseT/Half 10baseT/Full
                                100baseT/Half 100baseT/Full
                                1000baseT/Half 1000baseT/Full
        Advertised pause frame use: Symmetric Receive-only
        Advertised auto-negotiation: Yes
        Link partner advertised link modes:  10baseT/Half 10baseT/Full
                                             100baseT/Half 100baseT/Full
                                             1000baseT/Half 1000baseT/Full
        Link partner advertised pause frame use: No
        Link partner advertised auto-negotiation: Yes
        Speed: 1000Mb/s
        Duplex: Full
        Port: MII
        PHYAD: 0
        Transceiver: external
        Auto-negotiation: on
Cannot get wake-on-lan settings: Operation not permitted
        Current message level: 0x0000003d (61)
                               drv link timer ifdown ifup
        Link detected: yes

My Synology

root@DiskStation418j:~# ethtool eth0
Settings for eth0:
        Supported ports: [ TP MII ]
        Supported link modes:   10baseT/Half 10baseT/Full
                                100baseT/Half 100baseT/Full
                                1000baseT/Half 1000baseT/Full
        Supported pause frame use: No
        Supports auto-negotiation: Yes
        Advertised link modes:  10baseT/Half 10baseT/Full
                                100baseT/Half 100baseT/Full
                                1000baseT/Full
        Advertised pause frame use: Symmetric Receive-only
        Advertised auto-negotiation: Yes
        Link partner advertised link modes:  10baseT/Half 10baseT/Full
                                             100baseT/Half 100baseT/Full
                                             1000baseT/Half 1000baseT/Full
        Link partner advertised pause frame use: No
        Link partner advertised auto-negotiation: Yes
        Speed: 1000Mb/s
        Duplex: Full
        Port: MII
        PHYAD: 0
        Transceiver: internal
        Auto-negotiation: on
        Supports Wake-on: pumbg
        Wake-on: d
        Current message level: 0x00000033 (51)
                               drv probe ifdown ifup
        Link detected: yes

What a duplex mismatch is I understood but can not find a mistake.
The same problem I have when connecting to my second Diskstation.

root@DiskStation213j:~# ethtool eth0
Settings for eth0:
        Supported ports: [ TP MII ]
        Supported link modes:   10baseT/Half 10baseT/Full
                                100baseT/Half 100baseT/Full
                                1000baseT/Full
        Supported pause frame use: No
        Supports auto-negotiation: Yes
        Advertised link modes:  10baseT/Half 10baseT/Full
                                100baseT/Half 100baseT/Full
                                1000baseT/Half 1000baseT/Full
        Advertised pause frame use: No
        Advertised auto-negotiation: No
        Link partner advertised link modes:  10baseT/Half 10baseT/Full
                                             100baseT/Half 100baseT/Full
                                             1000baseT/Half 1000baseT/Full
        Link partner advertised pause frame use: No
        Link partner advertised auto-negotiation: Yes
        Speed: 1000Mb/s
        Duplex: Full
        Port: MII
        PHYAD: 1
        Transceiver: internal
        Auto-negotiation: on
        Supports Wake-on: g
        Wake-on: d
        Link detected: yes
0 Likes

#14

The ethtool results look fine and the network diagram suggests that there should be no loops.

It looks like the switches are managed (or semi-managed) , so it might be something in the configuration of the GS108EV3 that’s an issue.

You still haven’t provides the full logs or the iperf3 figures I requested. Having seen your network configuration, it would also be useful to see iperf3 figures (including reverse) between the Vero4K and Raspberry Pi3 that sits on the same switch. It seems that iperf3 is available on LibreELEC , though failing that, you could plug in an SD card containing OSMC or Raspbian on the Pi3.

0 Likes

#15

Here is the Log of the Vero (I edited the advancesettings because my password was still there in plain text. therefore no connection to the database in the log)

Summary

https://paste.osmc.tv/lerotuzofa

iperf3 is not running on my nose I have tried it

My last iperf :sleepy:

osmc@osmc:~$ iperf -R -c 192.168.178.66
------------------------------------------------------------
Client connecting to 192.168.178.66, TCP port 5001
TCP window size: 85.0 KByte (default)
------------------------------------------------------------
[  3] local 192.168.178.7 port 51929 connected with 192.168.178.66 port 5001
[ ID] Interval       Transfer     Bandwidth
[  3]  0.0-10.1 sec  29.4 MBytes  24.3 Mbits/sec
osmc@osmc:~$ iperf -c 192.168.178.66
------------------------------------------------------------
Client connecting to 192.168.178.66, TCP port 5001
TCP window size: 85.0 KByte (default)
------------------------------------------------------------
[  3] local 192.168.178.7 port 51934 connected with 192.168.178.66 port 5001
[ ID] Interval       Transfer     Bandwidth
[  3]  0.0-10.0 sec  38.2 MBytes  32.1 Mbits/sec

My iperf with the standard configured Pi

osmc@osmcpi:~$ iperf -c 192.168.178.66
------------------------------------------------------------
Client connecting to 192.168.178.66, TCP port 5001
TCP window size: 43.8 KByte (default)
------------------------------------------------------------
[  3] local 192.168.178.69 port 42190 connected with 192.168.178.66 port 5001
[ ID] Interval       Transfer     Bandwidth
[  3]  0.0-10.0 sec   112 MBytes  93.8 Mbits/sec
osmc@osmcpi:~$ iperf -R -c 192.168.178.66
------------------------------------------------------------
Client connecting to 192.168.178.66, TCP port 5001
TCP window size: 43.8 KByte (default)
------------------------------------------------------------
[  3] local 192.168.178.69 port 42212 connected with 192.168.178.66 port 5001
[ ID] Interval       Transfer     Bandwidth
[  3]  0.0-10.0 sec   112 MBytes  94.2 Mbits/sec

and the log file from the pi if necessary.

Summary

https://paste.osmc.tv/conavoqutu

and the ethtool of my pi - is only 100 Mbits

osmc@osmcpi:~$ ethtool eth0
Settings for eth0:
        Supported ports: [ TP MII ]
        Supported link modes:   10baseT/Half 10baseT/Full
                                100baseT/Half 100baseT/Full
        Supported pause frame use: No
        Supports auto-negotiation: Yes
        Advertised link modes:  10baseT/Half 10baseT/Full
                                100baseT/Half 100baseT/Full
        Advertised pause frame use: Symmetric Receive-only
        Advertised auto-negotiation: Yes
        Link partner advertised link modes:  10baseT/Half 10baseT/Full
                                             100baseT/Half 100baseT/Full
        Link partner advertised pause frame use: Symmetric Receive-only
        Link partner advertised auto-negotiation: Yes
        Speed: 100Mb/s
        Duplex: Full
        Port: MII
        PHYAD: 1
        Transceiver: internal
        Auto-negotiation: on
Cannot get wake-on-lan settings: Operation not permitted
        Current message level: 0x00000007 (7)
                               drv probe link
        Link detected: yes

My Netgear GS108Ev3 is factory reset.

0 Likes

#16

I once hung the Vero directly to my Fritzbox.

osmc@osmc:~$ iperf -c 192.168.178.66
------------------------------------------------------------
Client connecting to 192.168.178.66, TCP port 5001
TCP window size: 85.0 KByte (default)
------------------------------------------------------------
[  3] local 192.168.178.7 port 53670 connected with 192.168.178.66 port 5001
[ ID] Interval       Transfer     Bandwidth
[  3]  0.0-10.0 sec  1.06 GBytes   913 Mbits/sec
osmc@osmc:~$ iperf -R -c 192.168.178.66
------------------------------------------------------------
Client connecting to 192.168.178.66, TCP port 5001
TCP window size: 85.0 KByte (default)
------------------------------------------------------------
[  3] local 192.168.178.7 port 53673 connected with 192.168.178.66 port 5001
[ ID] Interval       Transfer     Bandwidth
[  3]  0.0-10.0 sec  1.06 GBytes   912 Mbits/sec

That’s how it should be. Now I’ve hung the Vero times behind the second Netgear.

Fritzbox> Netgear V3> Netgear V2> Vero

osmc@osmc:~$ iperf -c 192.168.178.66
------------------------------------------------------------
Client connecting to 192.168.178.66, TCP port 5001
TCP window size: 85.0 KByte (default)
------------------------------------------------------------
[  3] local 192.168.178.7 port 58996 connected with 192.168.178.66 port 5001
[ ID] Interval       Transfer     Bandwidth
[  3]  0.0-10.0 sec   116 MBytes  97.4 Mbits/sec

Which setting prevents now in the Netgear the full speed. Even after the first Netgear the speed seems to increase.

I have testet set the speed to 100M Full and 10M Full

osmc@osmc:~$ iperf -c 192.168.178.66
------------------------------------------------------------
Client connecting to 192.168.178.66, TCP port 5001
TCP window size: 85.0 KByte (default)
------------------------------------------------------------
[  3] local 192.168.178.7 port 44964 connected with 192.168.178.66 port 5001
[ ID] Interval       Transfer     Bandwidth
[  3]  0.0-10.1 sec  16.8 MBytes  14.0 Mbits/sec
osmc@osmc:~$ iperf -c 192.168.178.66
------------------------------------------------------------
Client connecting to 192.168.178.66, TCP port 5001
TCP window size: 85.0 KByte (default)
------------------------------------------------------------
[  3] local 192.168.178.7 port 44972 connected with 192.168.178.66 port 5001
[ ID] Interval       Transfer     Bandwidth
[  3]  0.0-10.2 sec  4.50 MBytes  3.70 Mbits/sec
0 Likes

#17

Here are the ifconfig figures for eth0 on the Vero4K:

eth0: flags=-28605<UP,BROADCAST,RUNNING,MULTICAST,DYNAMIC>  mtu 1500
        inet 192.168.178.7  netmask 255.255.255.0  broadcast 192.168.178.255
        ether c4:4e:ac:28:28:c3  txqueuelen 1000  (Ethernet)
        RX packets 15580  bytes 1870606 (1.7 MiB)
        RX errors 0  dropped 524  overruns 0  frame 0
        TX packets 28328  bytes 39974982 (38.1 MiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
        device interrupt 40  

524 dropped packet on only 1.7 MB is not good.

And here are the ifconfig figures from the Pi:

eth0: flags=-28605<UP,BROADCAST,RUNNING,MULTICAST,DYNAMIC>  mtu 1500
        inet 192.168.178.69  netmask 255.255.255.0  broadcast 192.168.178.255
        ether b8:27:eb:75:d8:0d  txqueuelen 1000  (Ethernet)
        RX packets 106243  bytes 27099643 (25.8 MiB)
        RX errors 0  dropped 2882  overruns 0  frame 0
        TX packets 177919  bytes 249237373 (237.6 MiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

There you have 2882 dropped RX packets on 25.8 MB. While better than the Vero4K’s figures. they’re also very bad. They also suggest that it’s probably not a bad cable on the Vero4K.

Conclusion: When the Vero4K was directly connected to the Fritzbox it gave over 900 Mbits/sec, so I’m inclined to think that there’s probably something incorrect on the switch – either with the configuration or hardware.

0 Likes

#18

Then it must be due to the configuration. Because I tested with my two devices. The settings are almost the same.

0 Likes

#19

If you can put a cheap unmanaged switch instead of the GS108Ev3 it might help to clarify things. A 100-Mbit switch should be enough.

0 Likes

#20

Are you always plugging the Vero into the same port when its connected to the second switch? If so what happens if you move it into a different port. It is not unheard of to have individual ports go bad on a managed switch.

I also noticed you had this in your last log…

<memorysize>1048000000</memorysize>
<buffermode>1</buffermode> 
<readfactor>10</readfactor>

Perhaps I don’t understand how this works but it would seem to me that telling Kodi to use three gigs of ram on a machine that only has two and also telling it to try to fill that buffer at ten times the bitrate of the playing video might lead to issues outside of the other parts of this conversation.

0 Likes

#21

It might have changed in Kodi 18 but in Kodi 17 the “3-times memorysize” mentioned in the Kodi wiki is no longer correct.

Under Kodi 17, it would divide the memorysize into two halves and allocate 75% of the video cache to read-ahead caching. The other half would be used for audio caching, though will only allocate from RAM what it needs. So in this example, under Kodi 17 the read-ahead video cache would max out at around 375 MB.

1 Like

#22

I tried several ports from the switch. I had as described also swapped the switch.

Today I have also connected an unmanaged.

Fritzbox > Unmanaged TP-Link 5 Port > Vero 4k +
                                    > DS 418J
                                    > Netgear Switch > PC

The transmission rate varies between 2 and 32 M/bits from Vero to DS418

When I run Iperf on the PC and access the diskstation I have 942 - 975 M/bits.

When I access the Vero 4K Plus via PC

[368] local 192.168.178.2 port 5001 connected with 192.168.178.7 port 35464
[ ID] Interval       Transfer     Bandwidth
[368]  0.0- 1.0 sec  1.31 MBytes  11.0 Mbits/sec
[368]  1.0- 2.0 sec  0.26 MBytes  2.17 Mbits/sec
[368]  2.0- 3.0 sec  0.20 MBytes  1.67 Mbits/sec
[368]  3.0- 4.0 sec  0.19 MBytes  1.59 Mbits/sec
[368]  4.0- 5.0 sec  0.04 MBytes  0.32 Mbits/sec
[368]  5.0- 6.0 sec  0.78 MBytes  6.54 Mbits/sec
[368]  6.0- 7.0 sec  0.57 MBytes  4.75 Mbits/sec
[368]  7.0- 8.0 sec  0.48 MBytes  4.06 Mbits/sec
[368]  8.0- 9.0 sec  0.75 MBytes  6.26 Mbits/sec
[368]  9.0-10.0 sec  0.26 MBytes  2.16 Mbits/sec
[368]  0.0-10.3 sec  5.13 MBytes  4.19 Mbits/sec

I have the advancedsettings.xml now changed to

	<cache>
		<memorysize>524880000</memorysize>
		<buffermode>1</buffermode>
		<readfactor>5</readfactor>
	</cache>

My Kodi is updated to 18.2 RC1

0 Likes

#23

So now I have the Vero attached directly to the FritzBox again. The connection tested with

FritzBox Lan2 > Vero 4k+

[3] 0.0-10.0 sec 1.09 GBytes 938 Mbits / sec

Video all play wonderfully.
Now I have only the unmanaged switch between the Fritzbox and the vero and then breaks the speed.
FritzBox Lan2 > TP Link unmanaged 5 Port > Vero 4k+

[0.0] 0.0-10.0 sec 17.8 MBytes 14.8 Mbits / sec

Can not be that here is always the error in the switch. The cables are different every time.

0 Likes

#24

Just to be clear, is that between the Vero4K and the Syno NAS, with the FritzBox acting as the switch/router?

0 Likes

#25

The Fast

FritzBox 7590 Lan 1 > Netgear GS108EV3 -> Synology Diskstation 418j
FritzBox 7590 Lan 2 > Vero 4K+
NetGear GS108V3 Port 1> Netgear GS108EV2 > PC
                                                 

and the other slow

FritzBox 7590 Lan 1 > Netgear GS108EV3 -> Synology Diskstation 418j
FritzBox 7590 Lan 2 > TP Link 5 Port >  Vero 4K+
NetGear GS108V3 Port 1> Netgear GS108EV2 > PC
                                                 
0 Likes