Vero 4K+ - Logitech Harmony and CEC Reboot issues

Hi there!

I got my Vero 4K+ this week and as a newbie i run into some little problems… :wink:

My environment:

  • Sony 55XE9005 (4k TV)
  • Denon AVR-X2200W (Receiver)
  • Logitech Harmony 950 (IR-Remote)

First i got no picture at all but this is solved after changing the shipped HDMI-Cable to another one - solved

Second i got no 4k-output (only 1080p or a black screen) until i set the Denon to HDMI-passthrough and the Vero to adjust refresh rate - solved

Third the Vero always reboots if i power on the Denon AVR (not in a power off case). This must be a CEC issue but i can’t find a correspondingly setting - open problem

And forth i want to replace the original Vero remote with a Logitech Harmony 950 (only ir). In the Logitech Harmony software there is an OSMC Vero 4k predefined and on the Vero under MyOSMC - Remotes osmc-remote-lircd is selected. The key assignment will fit but every time i hit a button the Vero executes the command over and over again. The delay settings in the harmony do not change anything, also when i take the Harmony away the vero still executes the command. Same issue with the internal ir-receiver or the external ir-extender… - open problem

So any help would be great, thank you!

Greetings from Germany,


I recommend trying a different profile.
The Vero 4K profile wasn’t submitted by us.


I changed the profile to MS Xbox 360 (in the harmony software and in the MyOSMC setting) and it’s still the same…
Also the Vero still reboots when i turn on the AVR, even when i turn off the cec settings in the vero 4k+…

The Xbox remote profile will be slow (it’s RC5 IIRC).

Use a better remote profile if you can.

What do you mean by reboots? Does the screen go black for a second or two? In the latest update we added support for adjusting resolutions rate on HPD events. This resolved an issue where the Vero would boot at a lower resolution if it was turned on before the receiver / TV.

I wouldn’t mind, if the ir-remote control would be just slow… :wink:
It is like you would press a button all the time. I tried different profiles and two different harmonys (950 and One), it’s all the same - one short button-press and the comand will be repeated all the time…

Reboot: if i turn on the avr, the vero led switches from no light to red light and next on the tv there is a blue screen with the osmc-logo in the middle. No matter, if the hdmi hdp optinion is on or off.
I don’t think, i see the blue screen on a normal boot process but the time until i see the normal desktop is about the same…

It’s a CEC setting, not an HPD option.
Re. Remote: some other harmony users may be able to advise

I’ve deactivated the CEC module in the Vero, so what CEC setting this should be? No idea anymore…
I can’t deactive the HDMI CEC settings completely in the Denon AVR, because this will turn HDMI passthrough off and then i don’t get 4k video output, but i switched off all other control settings there.

Also, i found my old WD TV Live remote in a drawer, switched the ir remote profile in the Vero to it, and it’s still the same. So it’s definitly no Harmony issue, it’s a Vero issue. Is there any way to reset the ir module or is this a malfunction in my vero?

I tried to find some useful information in the debug logs and turned on debug logging and detailed libCEC logging.
Is the uploadlog.txt in the boot directory the only log i have to look at?

The only log entries belonging to the CEC issue are (i tuned on the AVR at that moment and the Vero does a reboot):

12:46:28.788 T:4082344528 INFO: Found input device /dev/input/event1
12:46:28.789 T:4082344528 INFO: opened device ‘cec_input’ (file name /dev/input/event1), m_bSkipNonKeyEvents 0
12:48:23.344 T:4082344528 INFO: Found input device /dev/input/event6
12:48:23.344 T:4082344528 INFO: opened device ‘eventlircd’ (file name /dev/input/event6), m_bSkipNonKeyEvents 0
12:48:23.344 T:3602354944 DEBUG: Thread CLinuxInputDevicesCheckHotplugged start, auto delete: false

And is this a normal behaviour? I only pressed the buttons on the IR-remote once…

12:50:43.227 T:4082344528 DEBUG: OnKey: 167 (0xa7, obc88) pressed, action is Down
12:50:56.828 T:4082344528 DEBUG: Previous line repeats 314 times.
12:50:57.245 T:4082344528 DEBUG: LIRC: Update - NEW at 157501:67 0 KEY_UP_UP linux-input-layer (KEY_UP_UP)
12:50:57.262 T:4082344528 DEBUG: LIRC: Update - NEW at 157518:67 0 KEY_UP linux-input-layer (KEY_UP)
12:50:57.262 T:4082344528 DEBUG: OnKey: 166 (0xa6, obc89) pressed, action is Up
12:51:05.816 T:4082344528 DEBUG: Previous line repeats 140 times.

No — it looks like the press is being stuck. What profile are you using?

It may benefit to record your own profile

I tried 3 different profiles (osmc-remote, wdtvlive-remote and xbox360), also 3 diferrent remote controller (harmony 950, harmony one and wd tv live), it’s all the same behaviour… So i’m quiet shure, it’s not a problem with a wrong profile!

Also interesting, it works as it should, after i installed a sd card, but only for 5 minutes until the next reboot. This sounds like a mechanical problem (loose connection or short circuit)…

And there is still the cec/reboot issue. It makes no difference, if i switch on or off the vero cec controller.

Overall, I think i got a device with malfunction (even the hdmi cable did not work). This sounds like a hardware issue…

But to mention it: the core funktions (video and audio) of the device are quite brilliant! :wink:

I just found the cause/solution for it and it was my fault (actually so simple - it hurts)… :blush:

I use a master/slave power strip and the vero power adapter was on a slave socket.
I didn’t thought about it because you don’t see the state of the vero 4K+ (no blue light)…

And i don’t understand the context at all but even the ir-remote works now without problems. :thinking:

I’m sorry about it!
Thanks for your help…