Vero 4k+ no Ethernet

Greetings. Very content user of this fine media player and quite pleased with the support when it was needed in the past.

I hadn’t been using Vero for a while and I thought I’d do a new install via usb.

Everything works perfect except Ethernet. I tried different cables, connecting directly to the vdsl router but no joy.

Ethernet eth0 seems to exist but “down” and no RX packets whatsoever.

I did try a couple older versions with no success. Willing to try whatever might work, pretty savvy with Linux as well. WiFi works just fine by the way.

Thanks for your time.

Did it work before?
Can you connect via WiFi and paste logs?

It did work last I used it but it was awhile ago. But fairly sure I tested it after I switched to gigabit too.

Certainly. I can do whatever logs you like, via Kodi myosmc addon you’d prefer?

https://osmc.tv/wiki/general/how-to-submit-a-useful-support-request/

1 Like

https://paste.osmc.tv/ehijafiruh

Difficult to say. I can’t see any evidence of the device detecting an ethernet connection. I’d expect to see something like

kernel: libphy: stmmac-0:08 - Link is Up - 100/Full

in the log. (That’s on my non-plus V4K.)

I see you’ve tried various cables and ethernet ports so it’s probably worth seeing if ethernet has been disabled:

connmanctl
technologies

If ethernet is disabled

enable ethernet

Thank you for your time, unfortunately no success:

osmc@osmc:~$ connmanctl technologies
/net/connman/technology/p2p
  Name = P2P
  Type = p2p
  Powered = False
  Connected = False
  Tethering = False
/net/connman/technology/ethernet
  Name = Wired
  Type = ethernet
  Powered = True
  Connected = False
  Tethering = False
/net/connman/technology/wifi
  Name = WiFi
  Type = wifi
  Powered = True
  Connected = True
  Tethering = False
/net/connman/technology/bluetooth
  Name = Bluetooth
  Type = bluetooth
  Powered = False
  Connected = False
  Tethering = False

osmc@osmc:~$ connmanctl enable ethernet
Error ethernet: Already enabled

Other than try a few more cables and ethernet devices, it might be worth completely powering off the device for a minute and also trying a different power supply (the Vero4K can also be powered through one of its USB ports).

1 Like

Are you sure this device is a 4K+?
Your logs suggest otherwise.

If it is, then the wrong Ethernet Device Tree is being loaded, which is why Ethernet isn’t working

Sam

1 Like

First of all thanks for your time again!

Yup 100% sure. You had helped me recover once a while ago when I’d botched it after trying a CE install, perhaps there lies the root of evil?

Yes, that will be the cause of the problem.
We need to make some changes.

Run this via the command line:

sudo fw_setenv revmodel '4kplus'
sudo fw_setenv initargs 'initargs=rootfstype=ramfs init=/init console=ttyS0,115200 no_console_suspend earlyprintk=aml-uart,0xc81004c0 ramoops.pstore_en=1 ramoops.record_size=0x8000 ramoops.console_size=0x4000 revision=4kplus'
dd if=/opt/vero3/uboot-vero4kplus.bin of=/dev/mmcblk0 conv=fsync bs=1 count=11
dd if=/opt/vero3/uboot-vero4kplus.bin of=/dev/mmcblk0 conv=fsync bs=512 skip=1 seek=1

Now reboot, and Ethernet should be working.

Everything works just fine now, thanks again for the amazing support.

1 Like

Glad to hear this.