Vero 4k not connecting at all to secured WiFi. (title updated - log included.)

Had a power outage today and since then the Vero 4k is not automatically connecting to my WiFi (I need to go into the app and manually connect after every reboot or disconnect) and my fstab isn’t auto mounting. If I use the “mount /mnt/dir/” everything is right again but it’s like it’s forgetting to do this on boot. What happened??

No idea. Post logs, please.

1 Like

Are you on the latest version of OSMC?

On latest version of OSMC. Problem has been getting worse… Can connect to unsecure wifi (sometimes) but not secure. Here’s a log.

paste.osmc.tv/nucapacada

I feel like I’m narrowing this down – but could still use some help.

osmc@osmc:/var/lib/connman$ connmanctl technologies
/net/connman/technology/p2p
Name = P2P
Type = p2p
Powered = False
Connected = False
Tethering = False
/net/connman/technology/wifi
Name = WiFi
Type = wifi
Powered = True
Connected = False
Tethering = False
/net/connman/technology/ethernet
Name = Wired
Type = ethernet
Powered = True
Connected = True
Tethering = False
/net/connman/technology/bluetooth
Name = Bluetooth
Type = bluetooth
Powered = False
Connected = False
Tethering = False
osmc@osmc:/var/lib/connman$ connmanctl wifi disable
Error ‘wifi’: Unknown command
osmc@osmc:/var/lib/connman$ connmanctl disable wifi
Disabled wifi
osmc@osmc:/var/lib/connman$ connmanctl enable wifi
Enabled wifi
osmc@osmc:/var/lib/connman$ connmanctl scan wifi
Scan completed for wifi
osmc@osmc:/var/lib/connman$

After scan wifi, try:

services

and you should see a list of networks

type agent on

and then

connect … (adding the service name)

Sam

It still didn’t connect but I removed the existing connman settings/config files and it fired right up. No idea what happened but I think my problems are solved. Thanks.

1 Like

Glad to hear this. Let us know if it happens again.

Sam