Vero 4k + Powered Hub won't work together

Long story short, when I plug the hub into the main box, it won’t turn on.

I have been using the Vero 4K with a 12TB hard drive as well as a separate 4TB hard drive with no problem. I purchased the hub to simply have both drives plugged in at the same time. I first tried plugging both drives into the hub, then plugging the hub into the Vero, and the Vero won’t turn on. I also noticed my drive turning off after a short period of time.

I also unplugged all drives as well as unplugged the hub from the Vero. The Vero turned on no problem. When I plugged the hub in (no hard drives connected), the Vero immediately shut off.

I am using the power and usb connections that came with the Vero and Hub.

Hi,

This sounds odd.

Can you try the hub in the other USB port?

What happens if you disconnect one of the power supplies?

Sam

Ah! unplugging the power from the hub actually made it work. That was easier than I thought. I guess it was getting too much power? Thanks for the quick reply!

Try changing the USB port that the hub is connected to.

Unplugging the power source from the OSMC hub got it to power on, but now only one out of two drives plugged into the hub is being recognized on the Vero. Is there a way to manually mount the second drive? It is showing that it is powered on.

How did you ascertain this?

Can you go to My OSMC -> Logs and chuck a log up?

Ideally if using powered drives, you want power from the hub.
I’m just trying to work out why that isn’t working.

Is the hub in the white or black USB port on the Vero?

Cheers

Sam

Here’s that log. I currently have the hub plugged into the black port.
Only one of the drives is powered. The one that connects with no problem is the powered one. The one that is self powered is the one that doesn’t come up.

https://paste.osmc.tv/exesiraweb

Can you move the hub to the white (OTG) port?
and re-apply power to hub.

Sam

Just switched the hub over to the white port.
Still no recognizing the second drive.
Also, I am still going with power from the actual Vero, not the hub. When I plug in the hub’s power source, nothing happens.

Here’s the latest log:
https://paste.osmc.tv/akejadorap

Thanks

That’s odd.

I’ll check this over tomorrow. Getting a bit late now.

Sam

It is mounting Q_Film_01 which appears to be a 8TB drive. There do not appear to be any attempts to mount the 12TB drive.

Try with only the 12TB drive connected, and the hub powered.

One is self powered, But now I wonder if the self powered one is backfeeding…

Sorry, the 8TB is my large one, not 12TB

So the one not responding is only a 4TB. Should I attempt to use a powered drive instead?

Try with just the 4TB drive connected.

Which drive is self powered? the 4TB drive?

Can you please try the configuration

  • Vero with no power supply connected
  • USB hub with just its original power supply, connected via its uplink port to the Vero but no drives/devices in the USB host ports

If the Vero starts it means this USB hub is backfeeding power through its uplink port … which should not happen at all. I wouldn’t use such hub in any case.

Just to clarify: By shut off you mean you can see a red cross on the Vero’s front or are the LEDs dark?

Hi, I did some media managing this morning. It seems like my problem was the old self-powered drive. I transferred media to another powered drive and gave it the same name, and now both drives are coming up and playing as I was hoping. So it seems I’m good.

Jim, I didn’t try the above configuration, but let me know if you think it’s still worth looking in to. I now have the power going into the Vero (never got the hub to power without the Vero plugged in). The hub is connected to the white port on the Vero, and I have two powered hard drives connected to the hub.

Thanks for your help