Vero 4K randomly turning TV on


#1

First let me say I love my Vero 4K. It is by far the best media player I have ever owned. Having said that, I am having just one small and confusing issue.

For months now I will wake up in the morning and my TV will be on with the Vero 4K input selected. When I go to bed the TV is off. Somehow, at random times, and always during the middle of the night, the Vero 4K is causing my TV to come on and switch to that input. No other device I have connected to the TV causes it to do this, so I am assuming it is something to do with the Vero 4K. I was up last night and heard the TV come on at 4:18am and my Vero 4K was on the screen. This is the first time I have actually seen it happen.

Any ideas what could be causing this to happen? It is not really a problem, just confusing. Here is a log file I created. http://paste.osmc.tv/hoguxahazo There is an entry around 4:19am that may give some insight.

Thanks for any help!


#2

Go to Settings, Peripherals and disable set Active Source. It should resolve this for you


#3

Should be a CEC selection that includes configuration that Sam mentions here.


#4

Thanks for the info. Changed that settings, so hopefully that keeps the TV from coming on. Still curious as to why it would randomly do it though.


#5

CEC is a very complex (and buggy) affair and its support varies across devices.
I’ll look in to it in the near future when I get some time; but for now this workaround should suffice.

Sam


#6

First off, I never regretted switching to OSMC and the fabulous Vero 4K, thanks a lot!

So I have a Vero 4K connected via an Onkyo TX-SR608 receiver to a Samsung UE46C8700 TV. For a couple of days now, I’ve been observing the same symptom described by the initial post in this thread. The difference is that on some occasions, I only found the TV on. On other occasions, both the TV and the receiver were on. The receiver is configured not to re-route any signal.

After coming across this thread, I checked the settings under Settings/System/Input/Peripherals/CEC Adapter (libCEC 4.0.2 - firmware v5), I assume that’s the menu Sam was referring to in his post above. I noted that “Switch source to this device on startup” was enabled. I disabled it, but this has not changed the behavior. (CEC settings screenshot: https://imgur.com/a/MVGyGiB)

To isolate the source of the problem, I kept the Vero 4K turned off (but connected) for a few days, and the issue never occurred. With the Vero 4K back on, it was at most 24 hours until the TV was on again.

The problem never occurred before the latest OSMC system update, though that may be a coincidence.

Debug logs: https://paste.osmc.tv/zotuhufixo (turned on logs and restarted in the evening of January 12, around 10pm; the TV was on when I got up in the morning around 9am).

FWIW, some additional info, in case it is needed later or for others reading this:
(I have HDMI pass-through disabled).

  • HDMI pass-through is disabled on the receiver.
  • I updated the system last about ten days ago. I think the problem didn’t occur before the update (though I’m aware it may be coincidence).
  • I always put the Vero 4K to sleep using the Power/Suspend function before turning the TV and receiver off (light turns red and picture signal stops). On most days, the Vero 4K’s light has turned blue again in the morning. This has been a behavior for a long time though, before the current problems ever started, so I don’t think it’s directly related to this issue. And not that it bothers me much, but it would be interesting to know how the device could be prevented from turning itself on from the suspend state by itself.

Thanks in advance for your support!


#7

This will cause the problem.
In the last update, I made it so that we send a wake up signal when OSMC is woken from standby.

A debug log will likely show what’s waking up your device. My guess would be an add-on.


#8

Thanks for the quick answer Sam. Can you see anything in the log I provided? (Cf link in previous post.)

Edited to add:

I checked the log myself and found these lines:

09:00:03.187 T:4074623568    INFO: Toggle standby state is waking
09:00:03.188 T:4074623568    INFO: CApplication::ToggleStandby -- Toggle TMDS clock to 1
09:00:03.188 T:3673072384   DEBUG: Thread JobWorker start, auto delete: true
09:00:03.305 T:4074623568    INFO: CApplication::ToggleStandby -- Toggle LED brightness to 1
09:00:03.310 T:4074623568    INFO: CApplication::ToggleStandby -- governor will now be ondemand
09:00:03.315 T:4074623568    INFO: CApplication::ToggleStandby -- HPD locking will now be hpd_lock0
09:00:03.315 T:4074623568  NOTICE: CApplication::ToggleStandby -- checking for existence of /home/osmc/.kodi/userdata/wake.py
09:00:05.502 T:4074623568   DEBUG: ToggleDeviceState - waking up CEC device...

And right afterwards:

09:00:05.584 T:3673072384  NOTICE: VideoInfoScanner: Starting scan ..
09:00:05.584 T:4074619648   DEBUG: CAnnouncementManager - Announcement: OnScanStarted from xbmc
09:00:05.585 T:4074619648   DEBUG: GOT ANNOUNCEMENT, type: 16, from xbmc, message OnScanStarted

The only thing I found that correlates with this time is a crontab entry:

# m h  dom mon dow   command
0 9 * * * /home/osmc/update

This calls a script I made to update the library:

osmc@osmc:~$ cat /home/osmc/update 
#!/bin/sh
kodi-send --action="UpdateLibrary(video)"

I will test my hypothesis that the issue disappears if I comment out the cron job.

Sam, is it intended behavior that the UpdateLibrary message wakes the screen from standby?


#9

It’s not something we would have changed; so I suspect it is the intended behaviour, yes.


#10

I forget off the top of my head exactly what it is, but there is an option to not display library update progress, maybe that will help.


#11

This?


#12

Yes thats the option. Give that a try and see if that helps.


#13

Hi Brian,

Thanks again for your suggestion. I tried it out, the result was that independent of the setting of the option the device always comes out of standby. (I also searched in the Kodi source for a bit, but in the end did not find the bit where the messages are processed.)

While my main issue is solved (just have to rely on updating manually for now), out of curiosity I’d like to understand better the various systems involved. To what degree is the “Suspend” mode just a function of Kodi, and how much is the surrounding OSMC and Vero 4K system involved? Is it all triggered by Kodi alone, and the OS and hardware just react to it (e.g. by changing the led from blue to red, and back on wakeup)?

More to the point, what does the Suspend mode actually do, does it just turn off the HDMI signal, or is the Kodi process itself suspended?

I’m aware this is going far off topic of the post, so if anyone could just point me to some relevant documentation, I’d be more than happy.


#14

The suspend mode is not part of Kodi. We have just hooked up the functionality to this option and wrapped it around a dummy screensaver.

It turns off the HDMI TMDS clock – Kodi is still running; but it thinks it is running a screensaver.


#15

And CPU governer changed to Power save


#16

Thanks to both for the explanation!