Vero 4k+ refresh rate resets

I have the Vero 4k+ connected to an RCA RTU6549 TV set to 3840x2160 resolution @ 60Hz. I’ve noticed that if the TV is off and set to the HDMI input for the Vero 4k+, when I turn the TV on this will cause the refresh rate to get pushed to 30Hz on the Vero as well as reset the overscan/underscan settings for it so Kodi expands beyond the edge of the screen slightly. If I then check the settings in Kodi to change the refresh rate back to 60Hz it will only allow it to be set to 30Hz, as if the TV doesn’t support anything higher for this resolution.

To fix this I found I can do a few things but only one has been consistent so far:

  1. In the TV settings I can change the EDID Switch to something else (1.4, 2.0 or Auto) and then set it back to the original setting (2.0) and this will allow me to change the refresh rate back to 60Hz. This works inconsistently though, as of late it seems to be working much less often.

  2. On Kodi go to the power options and tell it to Exit or Reboot, afterwards I will have the option to change it to 60Hz again. This is another option that works inconsistently.

  3. Change the input on the TV to another input that is set to 3840x2160 @ 60Hz and then change it back to the Vero HDMI input. I have a Chromecast Ultra connected and I found switching to this and back allows the 60Hz option again. This method works 99% of the time (I recently discovered it and I don’t think it hasn’t worked yet).

I originally believed this was an issue with my TV - I know this is a cheaper 4k TV and was willing to just deal with it as such. However after I discovered method #3 above, I did some more testing and this refresh rate issue never happens when I turn the TV on while it’s set to the Chromecast Ultra’s HDMI input like it does with the Vero 4k+. In fact if I remember to change the input to the Chromecast Ultra before I turn the TV off, if I turn it back on then change input to the Vero 4k+ then it properly sets the refresh rate to 60Hz and everything is fine, the overscan/underscan settings for Kodi don’t need to be fixed either like I normally have to do each time.

I don’t have any other devices connected to the Vero 4k+, just the OSMC USB remote, HDMI cable (going to input 1 on the TV), ethernet and power. The version is currently the July 2019 update (2019.07-1). I did a quick search and didn’t see anyone else reporting this behaviour so I apologize if this has been covered somewhere else and I just haven’t seen it yet.

Thanks

So you set the Vero to 3840x2160? Or this is simply the TV resolution?

That is what I have set in the settings > system > display in Kodi.

You shouldn’t change the GUI to 4K
Instead set it to 1080p and enable adjust refresh rate.

Won’t that mean the 4K content I watch on it isn’t actually going to be in 4k?

That’s what Adjust refresh rate is for. It actually means adjust resolution and refresh rate.

Okay, perhaps I’m not familiar with the setting. Is it the one found in Settings > Player > Videos > Adjust display refresh rate ?

If so should I have that set to “Always”? That is how I currently set it up and I played one of the 4k movies I have and it played back in 1080p @ 60Hz instead of 3840x2160

Better to use ‘On start/stop’. With Always, the resolution/refreshrate can change in the middle of a video which is not good.

If you are not getting 4k output, please post logs so we can see what’s going on.

Which logs should I post, just the kodi.log? Should I enable any specific type of logging?

Just follow these instructions.

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device

  • reproduce the issue

  • upload the log set either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:

These logs contained several plaintext passwords I use so I’ve gone through and redacted what I could find. Here is a link to the logs: https://1drv.ms/t/s!AorVqzT1MwWwjy1prq1XIzcoO70j?e=tVAnvX

I did exactly as the instructions above told me to do. Rebooted after enabling debug logging then started playing a 4k movie - it does not change the resolution and continues to play in 1080p.

Your whitelist is screwed up
<setting id="videoscreen.whitelist">0192001080060.00000pstd,0384002160060.00000pstd,0384002160060.00000pstd</setting>

Try adding the rest of the supported Full HD and higher refresh rates or remove ALL whitelist resolutions.

I learned something new today, clearing the whitelist fixed it. I’ll use that setting on other boxes I have from now on. Thank you for the assistance everyone.

1 Like