Vero 4K Remote Issue


Since my purchase of the Vero 4K in late November I have had constant syncing issues with the remote it comes with.

If I follow the guide copied below the remote usually remains synced until the third or forth time the device has been turned back on, then I have to follow the process again:

However today the remote will not sync at all using this process and I cannot use it at all. Does anyone have any suggestions for what I can do?


Try pair it in another room or with another device.

Also see if you have a spare battery. When the battery is going, it will act sporadically


Hi Sam,

Shouldn’t be the battery as I have had it about six weeks, and for two of those weeks I wasn’t even using the device.

I have tried pairing it within another room to no avail.

Insert the dongle and post a set of logs
Do you see any lights on the remote when you press a button?


Hi Sam,

Bizarrely remote was working again when I turned it back on however logs are below if anything indicates a problem? If not should I take the logs again when it stops working?

Yes can still see a blue light on the remote when it is used.

Log -

That really sounds like a bad battery to me.

Ok thanks will try a new battery

If the remote falls out of sync it can hunt aggressively which will drain the battery quickly. Sometimes people go on holiday and come back to a flat battery. We’ve resolved this in a new hardware revision however it is a minor problem and shouldn’t affect many people.


Hi Sam,

I have tried a new battery and after pairing the device it worked until one power on/off cycle whereby today I still have the same issue.

I have included my logs for when the remove wasn’t syncing with the device, please find below.

Is there anything else I can try?

Your log doesn’t seem to show the dongle connected to the unit at all.

If you email we can swap this over for you.


Thanks Sam