Vero 4K Remote Not Working

I’ve purchased the Vero4K last year but it’s been an absolute nightmare, never ending problems with HDMI, so I’ve put the unit aside and haven’t been using it due to all the hassles with it disabling my sound bar functions.

Anyway I thought I might give it another try and download the latest firmware to see if they have fixed the issue, only to discover that now the remote is not even working.

I’ve replaced the battery, can see the blue light, but still no go.

Any ideas what to do next?

Please don’t post in 2 threads with the same problem.

Did you try re-pairing as suggested in the other thread? Did the lights blink like they should have?

I didn’t see the other thread until after I posted this…

And the other post seems to be already solved, i have tried those things but my problem is still not solved.

And what happened when you tried to re-pair?

Nothing, just the blue light blink on remote. I took out the USB, put back in, then hold the OK button for few seconds. Hope I did it correctly?

Re-read the above instructions and try again :wink:

1 Like

Do you have any further information about the problem you experienced?
I’ve checked, but couldn’t see that you raised any support request.

Obviously we cannot fix what we are not aware of. Did you try the basics:

  • Enable HPD Lock (for dodgy AVRs) under Settings -> Display and reboot
  • Change the HDMI cable

Unfortunately ‘HDMI problems’ aren’t really descriptive enough for us to know what the problem is, but I’m very confident that if you tell us what the problem is we can advise.

If you leave the remote for a significant period of time it will become unpaired. Fortunately this be can be re-established promptly.

I followed the instructions and it didn’t work for me this way, was getting worried, so I tried again, but this time having the receiver plugged in and NOT re-starting the unit and this did work, weird, but, seems to be ok now, thanks.

Good stuff.