Vero 4K+ slightly stuttering playback with 4K video

I’ve just setup my 4K+ using fstab method. It’s connected to a network attached storage device using gigabit ethernet. When playing back a 4K movie (video file size of around 15GB) picture quality is great but the motion is not very smooth. Seems to get very choppy especially during fast moving scenes. When I play the movie, it switches to 4K resolution at 24Hz. Is there anything I can do to improve it so it is smooth?

Thank you in advance

Does this happen with all files or just some?

Can you post a debug log when this occurs?

Thanks

Sam

Yes, I have four 4K movies (each around 15GB in size) and it was happening on all four of those. Two of those movies I also have in 1080p around 1 to 1.5GB in size and they didn’t have the same issue, nor did any of my other non-4K material. I’m not in front of the unit now but will post a log this evening. Which log are you wanting me to post? Do you mean the debug log from within the Kodi interface?

Many thanks

https://osmc.tv/wiki/general/how-to-submit-a-useful-support-request/

1 Like

Try to play it from local (SD Card or USB Stick) to exclude the network as an issue.
DO you have “Adjust Refresh Rate” set as “start/stop”?

Okay great, yes I will try that from local storage too and report back this evening. Yes, I have “Adjust Refresh Rate” set as “start/stop”. Thanks.

If those 4K movies are full length movies, then 15GB to me says that they have been re-encoded; so the problem may be with the encoding. A full length UHD movie should be 50GB (or more).

Okay, so I did some more testing and realised that of the four 4K movies that I have, 2 of them stutter very badly, the other two do not stutter badly at all (in fact, hardly at all). I tried them all off a USB key and each video seems to stutter about the same as when going across the network. I tried playing the stuttery videos on my PC (only has a 1920x1200 display) and it didn’t stutter as far as I could tell. I’m just grabbing the logs now.

Here’s the log: https://paste.osmc.tv/daxeyitizo

Posting mediainfo stats of the files will likely be helpful

Media info for the one that stutters the most: https://paste.osmc.tv/epocabeyun.tex

As I suspected, that is not a proper 4K file, it’s a re-encode. I’d suggest using MakeMKV, rip the disc again and not re-encode it.

Unfortunately, I don’t have the hard drive space to rip the disc without re-encoding to a smaller files size. The other movie I have seems to be fine though.

Could you provide a small sample of one of the problem files? When you re-encoded them, did you use the same settings? Mediainfo from one of the good files may be helpful.

But seriously, if you are re-encoding because of space issues, then why even rip the UHD version? Every UHD I’ve purchased comes with a Bluray copy. I’d suggest that you just rip the BD copy and save the UHD copy until you have the space to rip them properly. The way you are doing it now makes little sense to me; the re-encode is removing at least the 10 bit color and most likely the HDR, so all you have left is a lossy re-encode of a 4K video. A rip of the BD will probably look as good (if not better).

Okay, I’ll take a look. I have one of the early models of 4K tv that didn’t have HDR so not worried about losing HDR content. Also, having them on HDD means not having to change discs or potentially damaging the discs as they’re being handled. Many other benefits. Anyway, I’ll try the other things you suggested too. Thanks.