Vero 4k switching resolutions after latest update

Hi all, and thank you in advance for your time and support.
I’m using a Vero 4k (always on), through a Yamaha AV receiver to a Philips TV.
Since the last update, when the TV and AV are off for some time and I turn them back on, Kodi has changed the resolution randomly from 19201080p to 1024768, 1680*1050, or another resolution. I have to manually go back to System and change it back again, but it doesn’t hold.

Any idea how to fix this?

Thanks a lot!

That should not happen. Can you try re-starting Kodi while both AVR and TV are on with the correct resolution (to force the setting to be saved to disk). If that doesn’t work please post logs, noting the times you turned the AVR/TV off and on.

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device twice(!)

  • reproduce the issue

  • upload the log set (all configs and logs!) either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:

Hello, I thought I’d chip in on this issue since I am experiencing similar problems since the upgrade to v19.1. I first did an upgrade on a existing installation but there were problems with the resolution changing from 1920x1080p to 1920x1080i which makes the GUI flicker and looking blurred.

I therefore did a clean install from scratch but the problems remained. As I remember it, both after the upgrade and the clean install, the GUI was set by default to 1920x1080i as resolution, something I have never experienced before on the Vero 4K.

I have the Vero4K connected to a Sony RTH-G950 AVR via HDMI and then via HDMI to Sony KD-49XG9005 TV. See attached picture.

For me the issue seems to be intermittent, sometimes it changes during dim screensaver when a video is paused and then stopping the video and returning to GUI.
Sometimes it is caused by turning off the TV & AVR and then turning them back on. Over a longer period, most often overnight, the resoultion will have changed to 1920x1080i from 1920x1080p.

Sometimes after watching a video and return to the GUI the screen will be capped. If I then go into system settings and change the resoultion back and forth bwtween to resolutions, the screen is back to normal size again. The main problem seems to bee that the 1920x1080p resolution won’t stick in the systems settings.
I have gone through all the picture options for my TV but can’t rellay find anything that seems related, all seetings seem to be On “Auto”,
I haven’t changed anything since the upgrade either.

I’ve tried to replicate the issue but haven’t yet been able to find a method to do so, however I’ve done some logging with debug on in case there is something obvious information about what is going on.
Please let me know what I can do to help out to resolve the problems.

Logs available at

Nobody has any clues? It would be great to know if this behaviour is something that has a solution in the works or if there is a workaround meanwhile? Can I help out with further troubleshooting? Thanks in advance.

The problem with it switching to 1080i is a known bug and is being looked into.

1 Like

Do you have any news regarding this?
Let me know if I can help out with providing logs, testing etc.


Hopefully the issue is now addressed:

I’d appreciate it if you could test this and provide feedback before we potentially release this as an update to other users. To test this update:

  1. Login via the command line
  2. Edit the file /etc/apt/sources.list
  3. Add the following line: deb buster-devel main
  4. Run the following commands to update: sudo apt-get update && sudo apt-get dist-upgrade && reboot
  5. Your system should have have received the update.

Please see if the issue is resolved.

I also recommend you edit /etc/apt/sources.list again and remove the line that you added after updating. This will return you to the normal update channel.

Thank you for your swift reply. That is great news.

I will update from the staging repo right now and monitor the behavior over a day or two.

Out of interest, could you please get logs from the command line with both the AVR and TV switched off?

Yes sure, should I enable debug logging as per the general instruction for troubleshooting and post the link to the logs here?

Here’s the steps I performed:

  • Enabled debug logging at settings->system->logging

  • Rebooted the OSMC device twice

  • Turned off AVR & TV

Logs available at

1 Like

After doing some testing I can conclude the following;
The switching between 1080i & 1080p in the OSMC boot up is gone.

However, the issue with the resolution intermittently switiching isn’t unfortunately resolved yet.

After applying the update yesterday, I tuned off TV & AVR and let them stay off for approx. 20 min, after turning them back on, resolution changed to 1080i in Kodi GUI. After manually setting it back and letting the TV & AV being turned off during the night, the resolution stayed on 1080p this morning.

But when I started playback of a video and then exiting back to the GUI the resolution switched to 720p.
I tried to reproduce this behaviour with debugging on by switching back to 1080p, turning of TV & AVR and then playing the same video again. But this time there was no switching to 720p, the resolution stayed on 1080p.

I wish I could find a method to reproduce the issue every time, but the behaviour appears totally erratic to me.

This was an issue with the initramfs parsing logic for display capabilities and has been fixed in the staging repository for a while.

Ok, so after updating to the latest version in devel repo, the issues with the random switching of resolutions seems to be better. I need to test over a longer period to verify that it is 100% gone.

BUT, the problem with the Vero switching to 1080i after a period with the AVR and TV powered off is still there. At least I am now able to reproduce it with debugging on.

For this test , I enabled debugging, started playback of a video file, ended playback and navigated back to home screen before powering off AVR & TV and letting it sit there for approx. 25 minutes. Then turning TV & AVR back on to find that the resolution had changed to 1080i.

I hope this logfile can shed some more light on what is actually going on. It’s really becoming a nuissance to need to change the resolution back to 1080p in Kodi every day.

Let me know if/what I can do to help out. Thanks!

I’d suggest enabling HPD lock then.

HPD-lock and whitelisting resolutions? Or just HPD-lock?

Just HPD lock.

Great, thanks. Just another question; should HPD-lock be persistent? Because if I enable it and then reboot, the setting is disabled when Kodi is back up again.

Yes – it should stay enabled.

Try enabling it and going to Power → Exit instead of Reboot and see if it remains persistent.

Thank you, that worked, it is now persistent.
This seems to have solved my resolution switiching problems, I am very happy!

Just a last question; is enabling HPD lock in this scenario considered a workaround?
I guess my real question is; can I leave it as it is now or do I need to stay aware of any future changes?