Vero 4K+ turns TV back on when in Suspend mode

#21

Debug enabled logs will tell what wakes up the Vero

#23

https://paste.osmc.tv/jizocatibo

#24

This is what’s in the log file

2019-06-01 12:03:06.750 T:4064169984  NOTICE: Activating standby mode
2019-06-01 12:03:06.750 T:4064169984    INFO: Activating Vero standby mode
2019-06-01 12:03:06.750 T:4064169984    INFO: Toggle standby state is sleeping
2019-06-01 12:03:06.750 T:4064169984    INFO: CApplication::ToggleStandby -- Toggle TMDS clock to 0
2019-06-01 12:03:06.750 T:4064169984    INFO: CApplication::ToggleStandby -- Toggle LED brightness to 0
2019-06-01 12:03:06.753 T:4064169984    INFO: CApplication::ToggleStandby -- governor will now be powersave
2019-06-01 12:03:06.758 T:4064169984    INFO: CApplication::ToggleStandby -- HPD locking will now be hpd_lock1
2019-06-01 12:03:06.760 T:4064169984  NOTICE: CApplication::ToggleStandby -- checking for existence of /home/osmc/.kodi/userdata/standby.py
2019-06-01 12:03:06.761 T:4064169984   DEBUG: ------ Window Deinit () ------
2019-06-01 12:03:06.762 T:4064166624   DEBUG: CAnnouncementManager - Announcement: OnScreensaverActivated from xbmc
2019-06-01 12:03:06.764 T:4064166624   DEBUG: GOT ANNOUNCEMENT, type: 4, from xbmc, message OnScreensaverActivated
2019-06-01 12:03:06.769 T:3572486880   DEBUG: ProcessStandbyDevices - sending inactive source commands
2019-06-01 12:03:06.791 T:3812582112   DEBUG: Skin Helper Widgets --> Kodi_Monitor: sender xbmc - method: GUI.OnScreensaverActivated  - data: null
2019-06-01 12:03:06.813 T:4064169984   DEBUG: ------ Window Init () ------
2019-06-01 12:03:06.822 T:3820974816   DEBUG: Skin Helper Service --> Kodi_Monitor: sender xbmc - method: GUI.OnScreensaverActivated  - data: null
2019-06-01 12:03:27.249 T:4064169984  NOTICE: Activating standby mode
2019-06-01 12:03:27.250 T:4064169984    INFO: Activating Vero standby mode
2019-06-01 12:03:27.250 T:4064169984    INFO: Toggle standby state is waking

This is how it looks on mine

2019-06-01 14:18:27.899 T:4066312192  NOTICE: Activating standby mode
2019-06-01 14:18:27.899 T:4066312192    INFO: Activating Vero standby mode
2019-06-01 14:18:27.899 T:4066312192    INFO: Toggle standby state is sleeping
2019-06-01 14:18:27.899 T:4066312192    INFO: CApplication::ToggleStandby -- Toggle TMDS clock to 0
2019-06-01 14:18:27.899 T:4066312192    INFO: CApplication::ToggleStandby -- Toggle LED brightness to 0
2019-06-01 14:18:27.899 T:4066312192    INFO: CApplication::ToggleStandby -- governor will now be powersave
2019-06-01 14:18:27.904 T:4066312192    INFO: CApplication::ToggleStandby -- HPD locking will now be hpd_lock1
2019-06-01 14:18:27.906 T:4066312192  NOTICE: CApplication::ToggleStandby -- checking for existence of /home/osmc/.kodi/userdata/standby.py
2019-06-01 14:18:27.908 T:4066312192   DEBUG: ------ Window Deinit (Custom_Overlay_Debug.xml) ------
2019-06-01 14:18:27.908 T:4066308832   DEBUG: CAnnouncementManager - Announcement: OnScreensaverActivated from xbmc
2019-06-01 14:18:27.909 T:4066312192   DEBUG: ------ Window Deinit (DialogButtonMenu.xml) ------
2019-06-01 14:18:27.910 T:4066308832   DEBUG: GOT ANNOUNCEMENT, type: 4, from xbmc, message OnScreensaverActivated
2019-06-01 14:18:27.943 T:4066312192   DEBUG: ------ Window Init (Custom_Overlay_Debug.xml) ------
2019-06-01 14:18:27.972 T:4066312192   DEBUG: ------ Window Init () ------

So seems something related to screensaver or skin helper addon

#25

Thanks. Interesting.

I’ll play around.

#26

Try disabling skin helper addon

#27

I did that and no difference.

My Vero blue screened for some reason and I had to reinstall OSMC so good opportunity to test with a clean install using OSMC/Estuary screens and nothing else added.

Sadly, same issue. I didn’t get a chance to capture the logs and my my Vero is now fully loaded. But will try again after taking a backup and reinstalling.

#28

Hello, I’ve the similar problem. Steps to reproduce:

  1. Set the stand-by / suspend timeout to 5 minutes (minimum value).

  2. Manualy go to sleep mode. The LED goes to RED. The log shows (correctly) this:

2019-07-31 21:40:59.201 T:4069224448 NOTICE: Activating standby mode
2019-07-31 21:40:59.201 T:4069224448 INFO: Activating Vero standby mode
2019-07-31 21:40:59.201 T:4069224448 INFO: Toggle standby state is sleeping

  1. Now wait 5 minutes. After this time, the LED goes to BLUE and log shows this:

2019-07-31 21:45:59.597 T:4069224448 NOTICE: Activating standby mode
2019-07-31 21:45:59.597 T:4069224448 INFO: Activating Vero standby mode
2019-07-31 21:45:59.597 T:4069224448 INFO: Toggle standby state is waking

It seems that after manual going to sleep (step 2) the internal timer continues counting 5 minutes, and after this time, the event “Activating standby mode” occurs. Vero now tries to activate standby mode, but it uses the Toggle standby - so the Vero is now incorrectly waken-up.

The issue may be different, but this behaviour is reproductible and repeatable.

From my point of view, the fix should be following:
when the Sleep mode is activated manually, the standby timer should be stopped, so the “false” activating / waking up will never occur. Or, avoid the toggling.

#29

I would need to see full logs here (debugging enabled)
Does disabling suspend timeout resolve the issue?

#30

Full log (21:40:59 - Sleep mode activated manually in Kodi. 21:45:59 Vero woke-up itself without any user action; if HDMI-CEC activated, the TV has been also switched on)

2019-07-31 21:40:59.201 T:4069224448  NOTICE: Activating standby mode
2019-07-31 21:40:59.201 T:4069224448    INFO: Activating Vero standby mode
2019-07-31 21:40:59.201 T:4069224448    INFO: Toggle standby state is sleeping
2019-07-31 21:40:59.201 T:4069224448    INFO: CApplication::ToggleStandby -- Toggle TMDS clock to 0
2019-07-31 21:40:59.201 T:4069224448    INFO: CApplication::ToggleStandby -- Toggle LED brightness to 0
2019-07-31 21:40:59.201 T:4069224448    INFO: CApplication::ToggleStandby -- governor will now be powersave
2019-07-31 21:40:59.206 T:4069224448    INFO: CApplication::ToggleStandby -- HPD locking will now be hpd_lock1
2019-07-31 21:40:59.208 T:4069224448  NOTICE: CApplication::ToggleStandby -- checking for existence of /home/osmc/.kodi/userdata/standby.py
2019-07-31 21:40:59.209 T:4069224448   DEBUG: ------ Window Deinit () ------
2019-07-31 21:40:59.210 T:4069221088   DEBUG: CAnnouncementManager - Announcement: OnScreensaverActivated from xbmc
2019-07-31 21:40:59.210 T:4069224448   DEBUG: ------ Window Deinit (DialogButtonMenu.xml) ------
2019-07-31 21:40:59.211 T:4069221088   DEBUG: GOT ANNOUNCEMENT, type: 4, from xbmc, message OnScreensaverActivated
2019-07-31 21:40:59.228 T:4069224448   DEBUG: ------ Window Init () ------
2019-07-31 21:45:59.596 T:4069224448   DEBUG: Previous line repeats 1 times.
2019-07-31 21:45:59.597 T:4069224448  NOTICE: Activating standby mode
2019-07-31 21:45:59.597 T:4069224448    INFO: Activating Vero standby mode
2019-07-31 21:45:59.597 T:4069224448    INFO: Toggle standby state is waking
2019-07-31 21:45:59.598 T:4069224448    INFO: CApplication::ToggleStandby -- Toggle TMDS clock to 1
2019-07-31 21:45:59.718 T:4069224448    INFO: CApplication::ToggleStandby -- Toggle LED brightness to 1
2019-07-31 21:45:59.719 T:4069224448    INFO: CApplication::ToggleStandby -- governor will now be ondemand
2019-07-31 21:45:59.724 T:4069224448    INFO: CApplication::ToggleStandby -- HPD locking will now be hpd_lock0
2019-07-31 21:45:59.724 T:4069224448  NOTICE: CApplication::ToggleStandby -- checking for existence of /home/osmc/.kodi/userdata/wake.py

I think that the time period, after which the Vero wakes up (in the case above 5 minutes) is the same as the sleep timeout time set in power-saving settings. I’ll try to prove this hypothesis in the evening and I’ll write you the result.

I’ve tried another experiment yesterday evening: I have left Vero switched on. After a sleep timeout (5 minutes) the Vero fell asleep automatically (the LED went to RED) and remained sleeping. The unexpected wake-up didn’t occur (so the behaviour was correct).

Will prove again in the evening.

#31

Full logs means complete logs with debug enabled, not a snippet. Without them we can’t see configuration problems that could be relevant.

#32

Hello, the full log is here http://paste.osmc.tv/mopipeqoyo.
(full log with most add-ons and tvheadend disabled).

Important events:

  • at time 2019-08-01 18:04:33.695 I’ve manually put Vero to sleep (via menu) (LED went to Red)
  • at time 2019-08-01 18:09:33.964 (five minutes later = the power saving timeout set in Settings) the Vero woke up (without any external action) - LED went to blue.

It really seems that some timeout timer continues counting even if Vero was sent to Sleep mode manually, and after timeout it invokes another Sleep event, but the Toggle action wakes it up instead of falling asleep.

Turning TV on (when HDMI-CEC enabled) seems only to be a consequence of the above behaviour. Note than the above experiment was done with HDMI-CEC disabled on Vero as well as on TV.

I’ve done another experiment - I’ve increased the power-saving time to 10 minutes. The log show 10 mins difference between the above actions.

#34

Why enter suspend mode manually if a timer is set?

#35

Because I (and other people, eg children in my home) are used to switch off. Yes, you’re right, it is not necessary. But now I want to start to use HDMI-CEC (because in my country we are moving to DVB-T2 standard and I want to start using Vero as DVB-T2 tuner). And if somebody accidentaly uses this function, the TV will be turned on after some time automatically (because Vero wakes-up itself), and when waking up, it will turn on TV. And remain turned-on for example for whole night…

So I’m trying to find a correct solution how to use Vero as set-top-box for DVB-T2 and use only one remote control (TV’s or Vero’s) - for switching and controlling Vero and TV from single place. I just want to make the usage of TV and Vero as simple as possible for my children and my wife :slight_smile:

#36

Ideal behaviour could be following.
Only one remote control.
Switch everything ON (TV and Vero) by pressing single button (without waiting for booting of anything).
Simply watch TV or movies through Vero.
Switch everything OFF (TV and Vero) by pressing single button.
Or automatically switch everything OFF when idle for N minutes (if somebody forgets or fall asleep).

(and where switched OFF, save as much power as possible)

#38

Ok – need to think about this.

#40

Very interesting findings. I will check soon if disabling my power saving timeout will prevent also my 4K+ from waking up.

#41

I tested this for some time and I can confirm my issues are caused by the same behavior. It seems that with a suspend timer set the Vero 4k+ wakes up again after a manual suspend action.

[update]
Forgot to say but for me, now I know the cause, this is not a big issue anymore. I will just not use the manual suspend option again.