Vero 4K+ Will No Longer Turn On


I had through the forums a few times for this issue and tried a few things suggested on other threads. With my specific issue I initially reached out to support back on July 14th as nothing was working, but after two months with support I am now reaching out here to see if there are further suggestions.

Got in my device mid February and it was running fine for awhile until July 6th where it would show powered on but it was not putting out any signal over HDMI. Tried the TV it was normally connected to, my projector, and then my computer monitors. Also noted that it was no longer showing up on my network any more. At this point I reinstalled the firmware, specifically 20200607 using the directions on Download - OSMC

On July 13th it did the same thing. Tried the same steps but 20200607 showed an error message saying “Install Failed: Please Contact Support. Hardware is Faulty”. To verify I also tried 20200402 to get the same results. This is when I opened a ticket with support as I could not get the device to install.

On July 15th I was advised to use 20200603 instead as it was believed this was the concern as it is a version of the firmware not available through the software on the website. This one looks like it installed as I got past the error screen but it instead shows the installations screen for a few seconds, the bar scrolls, then the screen goes black. At this point the device shows a red light at the front of device and I was advised to leave it alone which I did.

After 2 hours passed with no change I unplugged it, left it alone for another 2 hours, and then plugged it back in. It showed as a clean new install, but then immediately started downloading an update and that it needed to reboot. I clicked on the Agree/OK option and then the device went back to the point that nothing was showing on screen and the red light was showing on the front of the device.

After some time I unplugged it, waited, then plugged it back in to get a “Please Wait” screen so I did and left it running over night.

On July 16th I repeated my steps, but this time I quickly went into settings and turned off updates. Instead I tried to load up the YouTube plugin, but screen goes black and light on front of device goes Red. So reached back out to support.

Did not hear back for a week so decided to try steps again with a different USB drive and then a brand new MicroSD card to get the exact same results of that it will install, crash, then I have to wait two hours before plugging device back in just to get a few moments of usability before it crashes again.

Only July 31st I get a response asking me to show the contents of my USB drive, which I supplied. This was due to the fact that there was some confusion on if there was an issue with my recovery drive.

At this point I had moved the Vero upstairs to my room to leave it unplugged for a minimum of 48 hours then try various things where I noticed that I suddenly was getting a green screen instead of a black screen. At first I thought this was unusual so I updated the ticket on August 3rd to mention this, but when trying to provide evidence of this I was able to see that this was actually the projector going to a green screen when it is not showing an active HDMI signal. On the TV and Computer Monitor this was the normal black screen with the red light on front.

I took further pictures of device and the screens that I was seeing as I was asked for further evidence of the errors that I was experiencing.

On August 10th I decided to try the device again as I had not heard back from support and it had been unplugged since August 4th. This time I got a completely different error message where it instead said
Waiting for root filesystem device /dev/ver-nand/root
FATAL ERROR: Could not find root filesystem device /dev/vero-nand/root - if this is a USB install please check the USB drive is connected
Serious file system corruption found. We will do our best to repair this now.
WARNING: OSMC cannot repair the filesystem and serious corruption may still exist. We recommend backing up any critical data and performing a fresh install of OSMC. Attempting to resume startup in …"

But after this I was able to do a fresh install and was even able to load up a video to my surprise. So I went to the settings menu to start to tweak things and the screen went black again. Except this time there was no red light on front of the device. The light on the SPDIF port was not lit anymore either and there was no way to tell if the device was even still working.

Tried waiting, unplugging, waiting, and plugging it back in. Black screen, no lights, and nothing showing that the device was even showing power. So I then updated the ticket again with the new screenshot of the error message I saw and the details that the device doesn’t even seem to show getting power any more.

On August 13th I was told that I would get an update shortly.

Earlier today I realized it had been 25 days since my last update so I updated the ticket to ask if there were any more details.

The response I got back was that they wanted attachments to show the problem.

I am at a loss for what further information I can provide at this time.

Thank you for your time!

Hi Stefan

I am awaiting some more details on the ticket on your behalf.

On 7/15, you stated that you had installed a pirate add-on (Seren) but after reinstalling OSMC, the device was functional. We can’t assist specifically with 3rd party add-ons.

Since 7/31 I am waiting for some images of the ‘green screen’ you report and a screenshot of the contents of your SD card/USB used for reimaging. You have provided a description of some JPEGs but have not attached them, so I cannot comment further at this time.

The red light on the front of the device should only be visible for a second or two during the boot process or when the unit is shut down / in standby.

Once you attach these images, I can advise further as I will have a better understanding of what is going on.




Thank you for your quick response and clarification. I have detailed the information requested below and attached the pictures.

On 07/15 I did state the plug-in that was initially installed to help with the trouble shooting process, but after the unit crashed that time I no longer used that plug-in, nor any plug-in, for future attempts at reinstalling.

On 08/04 I have the following pictures attached on my end along with the descriptions, but it sounds like they were unavailable on your end. I apologize for that as I was not aware that the attachments did not arrive at your end.

The initial error message that I received on that day once the unit would boot up can be seen at:

When I repeated the directions to reinstall the firmware I did get the ‘install screen’ for a second or more, but not enough time to provide a picture of that. Instead I took a picture of the unit to show that I only had power, HDMI, and the micro-SD installed but the unit was showing a red light on the front in the picture.

I waited two hours, but the unit was still not showing anything so I unplugged the power to force the unit to reboot and instead got this black screen on my computer monitor. On my projector the screen was green but was able to diagnose that was not due to the Vero unit, but instead is just it’s default color when nothing is currently being displayed. On the computer monitor and the television the screen is black instead.

I tried the Vero unit on all three display devices. In addition I tried additional configuration options with either having the recovery micro-sd in or the recovery USB drive plugged in instead. Then I tried with nothing plugged into the USB drive, the USB for the remote plugged in, any my keyboard plugged in only. With each of these configurations I tried booting it normally by leaving it unplugged for a few minutes, then plugging in the power. With the recovery micro-sd and USB drive configurations I also tried the additional step of holding down the button in the round port nearest to the HDMI port following the instructions at Reinstalling OSMC - Vero 4K - OSMC for a full minute.

On all configurations it stayed at the black/green screen so I left it unplugged. Over the time trying to troubleshoot the device I had noticed that leaving the device unplugged for a considerable amount of time was the only way to get it back to a responsive state.

On 08/10 I tried reinstalling the firmware again as the unit had been unplugged for 120 - 144 hours at this point. When the unit rebooted this time after the install screen went away the red light came on, but only for a second or two. This was unlike previous attempts where it stayed on until I unplugged the unit after two hours.

But, i was still having concerns as the following screen came up where i was able to take a picture

At this time I did one more install and successfully got the system to boot successfully.

This did not last long as while I was in the settings menu the screen went black again. This time however, the red light on the front of the device did not come on like it had done in the past. This is when I noticed that the red light usually visible in the SPDIF power was also no longer visible making it seem like the unit was no longer getting power.

I have tried it on my three display devices, plugged into multiple outlets both directly into a wall and into a power strip. I did not attempt a different power supply at this time as I only wanted to use the one that came with the unit to avoid complications.

Thank you greatly for your time.


This means that the installation media you have used is not working properly; or has not been imaged correctly.

My advice would be to reinstall, otherwise to return the device for inspection

At this time I feel it is better suited to send the device in as I can not tell if the device is receiving power at this time. Thank you for your hard work.

It’s always a good option to get hold of or buy a multimeter to measure the PSU (power supply unit). I have some SBCs as well and it’s a great help. Faulty SPUs is always a consideration.