Vero 4k Won't Turn On No Light After Update

There was a message on the screen saying the device didn’t update correctly and to reach out for support. After I hit ok, it black screened to a couple lines of text that I didn’t write down. When I unplugged the power and plugged it back it nothing is happening. No light, nothing on the screen. Not sure how to fix this.

https://osmc.tv/wiki/vero-4k/reinstalling-osmc/

1 Like

Please try re-installing OSMC as suggested by @darwindesign

Sam

Nothing happens when I plug the USB drive into the Vero. I tried a few times, one of the times the red light turned on, and the screen said please stand by. After 10 minutes I unplugged and tried again with nothing turning on. I tried relabeling the file recovery and holding a paper clip in the port next to the HDMI port with no luck. Any suggestions?

Were you having any kinds of issues prior to when you got the message the update failed?

No it was working great before

Please show a screenshot of the contents of the USB drive.
Please try with a micro SD card instead.

The micro sd card didn’t work either. Attached is the screenshot of my USB.

image

You may wish to contact support@osmc.tv to arrange repair.

Can I get an update on my repair? I’m not getting a response over email.

Can you let me know the ticket number?

Thanks

Sam

#843302 is in the email subject

Thanks. I’ll check this in the morning.

Thank you!