Vero 4k's temperature problem

I thought the reason my vero’s temp is high is because of Y cable but it wasn’t.
I got rid of it and I put normal direct cable with an external HDD as before.
However, I realized that if I just do nothing after reboot, temp is normal like 60C-ish. But if I play a movie even it’s just for a minute and then stop it, temp is started to go up and it stays near 85C even it’s idle. (No process working without kernel ones)

I need to help.


Are you checking the temperature under System Info? The constant redrawing of that screen may be increasing temperatures

Oh no. I check in command line.

Main menu was 5-8 degrees C higher then Video menu(Flies,addons.etc) in my experiences, using the OSMC skin

Weird thing is after watching a movie, kodi.bin process’ CPU usage is quite high like 20~80%. It’s fluctuating.
I think this could be one of reason temp is going high.

How is the movie encoded? Do you have hardware decoding enabled?

I don’t think it’s related to how to be encoded. It’s not when I’m watching it. It’s after I watch it. So Kodi just shows a movie list but the temperature is going higher and higher and reach to 84~86C and stays this level of temperature.

I tried to stop mediacenter and the temperature is going down right away.

Do you have add-ons installed on your system?


Yes, I installed Watchdog and Daum movie scraper which is Korean movie library.

I have been using them more than 1 year but had had no problem.

I realized that it happens when osmc is showing a movie list.

If I go back to home menu(first menu), the temperature is going down.

Do you know how to go back to home menu automatically or using command line?

Which skin are you using?
To me it sounds like whenever there is HDD disc access, the temperature rises unnecessarily so.

I just use OSMC skin. (not kodi one)

Do you experience the problem with the HDD disconnected?
Can you show us a photo of the setup?

No I’ve never experienced with disconnecting exHDD.
What setup photo should I show you?

Have you tried disabling those addons to see if it makes a difference?

Could you let me know how to disable them? (Not uninstall)

This should be possible under Settings -> Add-ons.
Watchdog has been known to cause some issues with stability in the past.


I’m tired of figuring out this temperature problem recently.

Some said it’s because of Watchdog so I disabled it and changed to Library Auto Update addon. (I even set the update period is 1hour)

It seemed okay but now temp is 90C again in idle.

What’s wrong… it wasn’t like this before.

Please post some new logs