Vero not booting even after reinstall (screenshot) HELP?

I just got the Vero in the mail and had been in the process of setting it up when the unhappy face error screen popped up and now it only gets so far before freezing when booting… I just tried reinstalling OSMC but continues to give me the same result!!!

Hi there,

Sorry to see you’re having problems. Your device is powering on, so that’s a more positive sign.

See if downloading and installing RC1 helps. Alternatively, if you have a spare SD card, you could give that a go and of course if there is a problem with the card we can replace it.

It would be good if you could let me know:

  • How you’ve connected the device (TV or monitor? HDMI or DVI?)
  • Can you try another tv temporarily?

Sorry for the inconvenience


Not an inconvenience at all :slight_smile:

I was using the HDMI cable provided. R1 did not work on the micro SD provided however I used the one from my pi and R2 is now installing files! I guess it was the SD card after all.

Best send you a new card then, please email