Vero2 is dead


my Vero2 stopped working after 1 hour. On TV and also on my Monitor the Screen keeps black. No DHCP entry no ARP so no SSH. I tried to reinstall whit an SD Card but this seems not to work, even after two hours the card is untouched, the kernel.img and filesystem.tar.xy are still there, no install log. The Card was prepared with your tool. I tried it with two different cards on two different PC´s with Windows 10 even with Ubuntu, all with the same result.

So I think this Vero2 is dead.

Regards Robert

@DBMandrake managed to brick his device too this evening and we managed to get things restored, even after he erased his bootloader.

I’m working on an automated solution and will update you when we have some progress


Can you be a bit more specific about what was happening when it stopped working ? Were you using the device at the time, if so doing what ? Or did it not work upon switching it on ?

Is the blue LED still lit ? While Sam works on his recovery tool I have something you can try:

Create an installer image on an SD card using the OSMC installer, then re-insert the card in your PC/mac and rename the file kernel.img to recovery.img. Choose to safely eject then insert the card in the Vero 2 with the power off.

Find a tooth pick or similar non conductive tool (do not use a paper clip) and carefully insert it into the analog audio socket at the back - this is the small round one beside the HDMI socket. You will feel a little bit of resistance at the end - push it slightly harder and you should feel a small button click.

Keep this button held down while you or someone else connects the power to the device. Keep the button held down for at least 30 seconds or until you see the installer screen come up. Let us know if that works for you - if it does it gives us a lot better idea of what your problem might be, and if the installer does appear reinstallation should be successful.

1 Like

It was around the 2nd of march, the day I received my Vero2. I was set up the new device, Language, Timezone, Network and so on, do a search for updates, vero found one and installed it. Added my Network Shares and tried to watch a Film.

Then the CEC stooped working at all, the time before only every second or third keystroke was recognized. So I searched the remote control who was shipped with the Vero. This still works fine, so with this I told the Vero to reboot. This was the last I have seen from it.


This works, the Vero2 is back, thanks for your help.

Regards Robert

Install Log: (maybe it helps you)

Thu Jan 1 00:00:05 1970 Starting OSMC installer
Thu Jan 1 00:00:09 1970 Detecting device we are running on
Thu Jan 1 00:00:09 1970 Mounting boot filesystem
Thu Jan 1 00:00:09 1970 Trying to mount to MNT_BOOT (/mnt/boot)
Thu Jan 1 00:00:09 1970 Using device->boot: /dev/mmcblk0p1 and FS: fat32
Thu Jan 1 00:00:09 1970 No preseed file was found
Thu Jan 1 00:00:09 1970 Creating root partition
Thu Jan 1 00:00:11 1970 Calling fmtpart for partition /dev/vero-nand/root and fstype ext4
Thu Jan 1 00:00:23 1970 Filesystem label=
OS type: Linux
Block size=4096 (log=2)
Fragment size=4096 (log=2)
Stride=2 blocks, Stripe width=1024 blocks
415344 inodes, 1658880 blocks
82944 blocks (5.00%) reserved for the super user
First data block=0
Maximum filesystem blocks=1698693120
51 block groups
32768 blocks per group, 32768 fragments per group
8144 inodes per group
Superblock backups stored on blocks:
32768, 98304, 163840, 229376, 294912, 819200, 884736, 1605632

Allocating group tables: 0/51 done
Writing inode tables: 0/51 done
Creating journal (32768 blocks): done
Writing superblocks and filesystem accounting information: 0/51 done

Thu Jan 1 00:00:23 1970 From a root partition of /dev/vero-nand/root, I have deduced a base device of /dev/vero-nand/roo
Thu Jan 1 00:00:23 1970 Mounting root
Thu Jan 1 00:00:23 1970 Trying to mount to MNT_ROOT (/mnt/root)
Thu Jan 1 00:00:23 1970 Using device->root: /dev/vero-nand/root
Thu Jan 1 00:00:23 1970 Extracting files to root filesystem
Thu Jan 1 00:00:23 1970 Starting extract progress…
Thu Jan 1 00:01:28 1970 Extraction of root filesystem completed
Thu Jan 1 00:01:28 1970 Configuring bootloader
Thu Jan 1 00:01:28 1970 Configuring bootloader: moving /boot to appropriate boot partition
Thu Jan 1 00:01:32 1970 Configuring boot cmdline
Thu Jan 1 00:01:32 1970 Configuring /etc/fstab
Thu Jan 1 00:01:32 1970 Successful installation. Dumping log and rebooting system

Glad to hear it’s working again. The fact that it was able to boot recovery.img with the recovery button held down does confirm our suspicions of one thing that is going wrong and preventing a “normal” re-installation. It doesn’t necessarily explain how or why it happened in the first place but we have some ideas on that too that we are investigating.

Getting to the bottom of the underlying cause of this issue and fixing it is top priority for us, even though both Sam and I are unable to reproduce the problem first hand on our own devices. (I did accidentally corrupt my install once updating to a known bad update, but aside from that I have not had any corruption problems like this in all the time I have been testing my Vero 2 which makes trying to find this problem quite frustrating)