Vero2 June update didn't update armv7-eventlirc-osmc (dependency problem)

20/06/2016 about 15:00

here are your how to help questions and my answers:

During (June) update I got a message: </b>
    An error occurred while updating the following package
    <please report this to the OSMC forum.>
    restarting in 30sec

But the Vero2 had hung. It didn't respond to its remote control. 

It did not respond to an ssh login via putty (timeout)

I have not enabled debug logging at this point: nevertheless the 10th 

instance of lirc in the logs may be useful.

debug log when I tried to update again,

(dependency problems)

What you were doing when this issue occurred

I responded yes to an invitation to perform an update on vero2, then 

switched the TV to display HDMI 1 (a sony pvr) to watch recorded motor sport.
the PVR shut down cleanly, but unexpectedly after a couple of minutes. On request,
It powered up fine and continued. After a few minutes watching,
I switched to HDMI2 (= vero2 connection)
The error message above was waiting for me.

Whether you can replicate this issue on demand. If you can, then please
provide some steps on how an OSMC developer can reproduce the same

I have not tried yet.

p.s. retrying the update with debugging on gives similar error messages in the log, but
did not prompt me onscreen to report. see below. 20/06/2016 from 17:00

The message implied I should report this issue at once. 

While researching how to report I discover that I may have to turn logging on and
reproduce the fault. That will be in a later post.

The device you are currently running
OSMC on Vero 2 about 1 month since purchase.

What peripherals are attached to the device?

HP 16Gb USB stick
Vero remote, with dongle on the side.

I read the dongle should be at the back, so I tried repositioning 
it there, but it would not respond. I reverted to usb at the side. 
It works, but sometimes need debouncing.

Has this issue been introduced by a new version of OSMC?

When did the issue first appear

about 15:00 20/06/2015

and can you recall a time when it was not present?

Yes,  Earlier

Vero2 with OSMC was restarted by re-plugging. While power off I moved
the remote control dongle to the rear port & unplugged the USB stick.

restart. Remote control working in rear port
copy logs to SDcard (none visible with card in PC)
upload logs seems to have worked.

restart, enabled debug logging.
requested settings backup (presumably to usb stick)
request restart

a stop job is running on HPstick (time1, time2)
about 10 mins later,

“target shutdown reached.”

~17:30 no restart

18:09 power cycled
backed up settings
my Osmc / updates/ manual /backup settings

new log shows similar error to before:

Preparing to unpack …/armv7-eventlircd-osmc_1.2.0_armhf.deb …
Unpacking armv7-eventlircd-osmc (1.2.0) over (1.1.9) …
Setting up armv7-eventlircd-osmc (1.2.0) …
dpkg: error processing package armv7-eventlircd-osmc (–configure):
armv7-remote-osmc depends on armv7-eventlircd-osmc; however:
Package armv7-eventlircd-osmc is not configured yet.

Upgrade: vero2-kernel-osmc:armhf (2.6.8, 2.8.0), …,
armv7-eventlircd-osmc:armhf (1.1.9, …



sudo apt-get update
sudo apt-get -f install

For this type of problem its sometimes necessary to attempt to install the offending package manually to get further useful information. So can you try the following via SSH and paste the results here using the formatted text </> tags:

sudo apt-get install -f armv7-eventlircd-osmc

PS the strange thing is according to the list of packages installed you already have eventlircd 1.2.0 installed (which is the current version) and dmesg shows eventlircd starting and functioning normally - so I’m puzzled as to why it is still causing an update error.

I had the same error message but resolved via a reinstall of tvheadend through the myOSMC menu

Hl DBMandrake, Thanks for investigating this. Before I saw your message,
I took Sam’s advice

SSH session;
sudo apt-get update
sudo apt-get -f install

I confirmed removal of various heimdal packages.

and then ran those two commands again, but it was stable.

at the display on TV
about 11am, message Updates available; Install?
I confirmed YES/OK with the remote.

I uploaded the log to

The remote is working and I think the update has been done properly this time.

So I doubt that the Vero2 will display the fault I reported. However, if you want me to pursue this, get back to me.

Unless you tell me not to, I’m going to turn debugging off and say case closed.

Here are a few lines from the log that give me confidence.

Log started: 2016-06-22 10:59:06
Preparing to unpack …/base-files-osmc_1.9.5_all.deb …
Unpacking base-files-osmc (1.9.5) over (1.9.4) …
Setting up base-files-osmc (1.9.5) …
Log ended: 2016-06-22 10:59:11

10:59:24 T:3031162880 NOTICE: Kodi compiled Jun 19 2016 by GCC 4.9.2 for Linux ARM (Thumb) 32-bit version 3.16.7 (200711)
10:59:25 T:3002070000 INFO: LIRC Process: using: /var/run/lirc/lircd
10:59:25 T:3002070000 INFO: LIRC Connect: successfully started
11:00:17 T:3031162880 DEBUG: LIRC: Update - NEW at 53217:160 0 KEY_OK linux-input-layer (KEY_OK)

thanks again

TVHeadend…? Interesting. Yes I have it running too, but I’ve not got my TV-stick configured yet. There could have been an interaction between the remote’s software & tvheadend’s.

Looks like it is working OK now.