Vero4 Suspicious plug-in descriptor

Hi
Vero4 , update with the first Stretch version

I have this line in my error log, (nothing new, I can found the message in logs from october 2017)

Loading: /usr/lib/kodi/system/libcpluff-arm.so
12:28:37.975 T:4076274256   DEBUG: ADDON: cpluff: 'Suspicious plug-in descriptor content in /usr/share/kodi/addons/skin.osmc/addon.xml, line 19, column 2 (ignoring unexpected element assets and its contents).'

I’m interesting to know a little bit more what’s happen ?? The last “Google” infos are from 2016

Merci ,
Michael

The file is:

<?xml version="1.0" encoding="UTF-8"?>
<addon
        id="skin.osmc"
        version="17.0.1"
        name="OSMC Skin"
        provider-name="OSMC">
        <requires>
                <import addon="xbmc.gui" version="5.12.0"/>
        </requires>
        <extension point="xbmc.gui.skin" defaultthemename="Textures.xbt" effectslowdown="1.00" debugging="false">
                <res width="1920" height="1080" aspect="16:9" default="true" folder="16x9" />
        </extension>
        <extension point="xbmc.addon.metadata">
                <platform>all</platform>
                <summary lang="en">The default skin for OSMC</summary>
                <description lang="en">Original design: Bolteh[CR]Original Kodi skin: Hitcher</description>
                <news>Fix crash in PVR guide window; Font updates</news>
        </extension>
        <assets>
                <icon>icon.png</icon>
                <fanart>extras/backgrounds/Default.png</fanart>
        </assets>
</addon>

Check that it’s the same on your system and not corrupted.
It parses fine, but it may be a warning that <assets> is deprecated.

Hi sam, thanks for the reply

I found

> <?xml version="1.0" encoding="UTF-8"?>
> <addon
>         id="skin.osmc"
>         version="17.0.2"
>         name="OSMC Skin"
>         provider-name="OSMC">
>         <requires>
>                 <import addon="xbmc.gui" version="5.12.0"/>
>         </requires>
>         <extension point="xbmc.gui.skin" defaultthemename="Textures.xbt" effect$
>                 <res width="1920" height="1080" aspect="16:9" default="true" fo$
>         </extension>
>         <extension point="xbmc.addon.metadata">
>                 <platform>all</platform>
>                 <summary lang="en">The default skin for OSMC</summary>
>                 <description lang="en">Original design: Bolteh[CR]Original Kodi$
>                 <news>Fix crash in PVR guide window; Font updates</news>
>         </extension>
>         <assets>
>                 <icon>icon.png</icon>
>                 <fanart>extras/backgrounds/Default.png</fanart>
>         </assets>
> </addon>

Only version number is different, but file is dated from 9/4/2017
I don’t use the osmc skin and I use also french language

It’s nothing to worry about. I believe the <assets> tags are just being ignored by Kodi’s plugin manager.

Ok another warning…
FYI: Next week I open a Kodi Thread for my thumbnails issue (FWscale) I need to understand whats reallyhappen. Everytime when I’ve a Kodi issue I see the message in my logs (with ffmpeg debug enabled)

Michael