Vero4K accidentally set to wrong resolution - now just get a black screen

Hi, I have a Vero4k plugged directly into my TV, and after a system update yesterday the GUI ended up set to a low resolution. I went into the settings to change the resolution and accidentally set it to 4096x2160 instead of the 3840x2160 that my TV supports. Now all I can see on the Vero is a black screen. I can tell that it is on and working since I can hear the clicking noise when moving between menu items, but I cannot change the resolution back to one that my TV supports since I can’t see anything.

Is there any way I can revert the Vero4K to any other resolution without being able to see what I’m doing?

Edit guisettings.xml by finding the problem resolution and set it to the desired.

sudo systemctl stop mediacenter
sudo nano ~/.kodi/userdata/guisettings.xml
sudo systemctl start mediacenter

Additionally, you should leave this setting at 1080p and enable adjust refresh rate. The Kodi GUI has not yet been optimized for 4k and your TV will do a better job upscaling. With adjust refresh rate enabled then Kodi will playback your 4k media at it’s proper resolution.

Hi, thanks for the reply. I’ve managed to work out how to SSH to the Vero and after some trial and error and some searching discovered that you meant sudo systemctl stop mediacenter. However I cannot see any settings related to resolution in guisettings.xml and I’ve failed to find anything in the wiki describing them. Is there another place they could be stored?

Try this

Edit: nevermind :wink:

Solved! Being a newbie I didn’t realise that nano was only showing me the first page of guisettings.xml :smiley: Found it and fixed, many thanks for the help ActionA.