Vero4K Issues Similar To Earlier Vero Issues

Over the past few years, I have used Vero from 1 through to 4K. I have a list of recurring issues I hoped would go away with Vero4K but they continue to happen - some I have reported and others I haven’t. I’m starting this post as now I have forked out money again I would like to see if there are any resolutions to stop these annoyances from occurring. I understand that since some of these issues have happened over different devices it may be in my particular set up - I just would like some guidance to try and resolve them. Yes I have looked through this forum - but I’ve spent so much time over the years I’d like some help. I will list them one at a time so as not to make this too confusing.

Vero 4K via Ethernet to NetGear C6300BD Cable Modem via Ethernet to Drobo 5N NAS using SMB Shares
Vero 4K via HDMI Cable to LG - OLED TV - 55EC930T to Optical Out into 250W RMS Basic Tube Amp to ELAC Speakers
Control Devices:
I variously use Kodi Remote App, LG Magic Remote, and OSMC Included Remote + Dongle
Additional Devices:
USB Keyboard permanently attached.

I use Confluence as I am used to it and the other skins don’t do it for me (yet). After configuring Vero4K once it arrived, I’ve had one or two crashes that lead to a sad face and then a reboot. Upon reboot, some non-default configuration settings were lost (weather no longer on home page, had to add OpenWeather add-on again, rechecked "Don’t Display File Extensions, etc). This happened to me with Vero 2 on occasion and quite soon after getting the Vero4K.

Is there something I can do to stop the occasional loss of settings from happening?

That is a known issue that only came since the February update. A solution is being worked on as you could read in the related threads here on the forum.

May well be an issue in the latest update for 4K, but has happened to me over the last year with Vero 2. Will wait for the update and anyone else’s comments before moving to next issue.

Do you have a post to report this issue over the last year? I’m only aware of this becoming a problem since Kodi Krypton was released


No Sam, you have enough on your plate over the years so I’ve left these little niggling issues alone until now, hoping they would be resolved in new updates or devices. But after buying at least 4 Vero devices now I’ve reached a point where I want to be able to leave my Vero turned on and have it work without these annoying issues that either require me to reboot, re-image, or put up with the inconsistencies disappear for AT LEAST 6 months. I’ve tried using the forums but much of what I read is foreign to me or doesn’t quite address my issues, and I’ve never been able to have my Veros just work continuously for more than a few weeks at most before something else happens.

I’ll wait for the update and see if it works before I move on to my next problem.

Hi @rawnet

I am happy to help you put any of these issues right. Currently there is a bug with skin and other settings disappearing on reboots and it affects all platforms. Hopefully after this Sunday that will be resolved, and you’ll then be able to enjoy persistence by selecting Shutdown -> Power Off and then removing power whenever you want.


I remember posting about skin reverting to default and losing settings in the past @ Skin regularly reverts to OSMC standard skin after reboots by itself since last update on my Vero... :-( - Help and Support - OSMC Forums

That post was in 2015 and was a similar issue, but shortly fixed thereafter. It hasn’t been present since then or we would have had more reports.

Same here, on the 2 different rpi, loosing setting on reboot :frowning:

As said previously, we are aware of a problem that affects all platforms. Please don’t threadjack this user’s post so that in the unlikely event these problems do persist after we announce them as fixed they are able to get their problem resolved.

When the problem is solved we will let you know.


Well, Sam, after using Vero4K for a few months after this OP, I am happy to report that all niggling issues that have plagued my use of Vero for years have all disappeared.

No longer do I change the input back to the Vero and get a black screen on my LG OLED, my LG Magic Remote work every time (after a minute or two), all settings are remembered between reboots, I have not had a frozen screen for months, and I have finally been able to leave the Vero4K in always on mode every single time.

My faith in Vero is restored - thank you to you and the team! This thread can be closed…

1 Like

Glad to hear this!