Vero4k Questions/problems

  • How do i disable subtitles. (I want them off by default)
  • How do i add a simple windows share as a media source? When trying to “browse” i get an instant “error 2” and when trying to manually add the whole thing just freezes after I’ve spent 10 minutes putting in all the details.
  • 4k playback doesn’t work. 1 out of 2 files i have to test with is jerky and unwatchable.
  • Despite setting my number of audio channels as “5.1”, the audio on lots of files isn’t working properly. No centre channel, quiet surrounds, etc. I think normal DD 5.1 files are working ok. Tried with and without audio passthrough, no change, whats happening here?
  • Why can’t Yatse see it like it can on my RPi2?
  • Why aren’t folders being placed at the start? Can i change this?
  • Why isn’t there a power button on the remote? And how do i turn it back on again?

Audio -> Set as default for all movies.

Did you add via IP or try to browse for shares? Browsing isn’t always reliable, particularly given how much Samba has now diverged. Try using a static IP and entering the share exactly.

It certainly does work. Which clip didn’t work for you?

Can you show me your audio settings and debug log?

Did you try closing the Yatse app and reopening it? Is the web server enabled? Did you try manually adding it to Yatse?

I don’t understand.

The Vero 4K is expected to be an always-on device.

Thanks, i’ll have another go with some of this.

The 4k playback i guess is the most worrying, it was just a random webrip of “warcraft”, plays fine on my PC, vero can’t handle it, unless its the wifi that can’t handle it, will try it on cable to check.

Upload MediaInfo, debug log and a sample and I’ll take a look. Also try playing the file locally: Samba is a very inefficient protocol, and for 4K you might be better using something else

FYI i was using DLNA when i had this problem, i haven’t managed to test it with SMB yet cos i still can’t get the vero to see my server.

Just add the IP as host name resolution isn’t always reliable depending on people’s network environments

I’ve tried pretty much every combo i think of, it always results in either a total freeze or “network unreachable”.

What syntax should i be using for the form? I would have expected just “\servername\share” but there is a separate box for share, should i be using backspaces? Have tried replacing name with IP.

can you try 4K content from here, i have tested most of them on my own Vero 4K and they all played fine:

http://www.4ktv.de/testvideos/

I could- but test files aren’t much use to me, if actual content doesn’t work.

Have given up on the SMB for now and have been trying to get the sound working.

I had a suspicion i might not be able to use this untill i get a proper AV amp- nothing that has DTS is working properly, even just standard 5.1 files, with any combination of settings. The C channel is always missing at least. This is the same with an ARC connection through the TV or an optical connection.

FYI: The 4k file thats all choppy, the “skip” counter is constantly moving up. Not sure why, the video bitrate is only 5-7Mb/s ish.

I tried one of the examples, and the bit-rate was too high, resulting in buffering.

That shouldn’t be the case. I believe @DBMandrake @ActionA and @joakim_s have been testing their devices for a while pre-launch, and that they do not have an AVR receiver. Please show us your audio settings.

I need a log, MediaInfo and a sample clip. Do you have Adjust Refresh Rate enabled? I would recommend enabling it for smooth playback.

To be clear the device i have is a 5.1 all in one samsung system that i’ve used successfully with my Tvs DLNA player to playback pretty much anything inc DTS stuff, and i’ve used the optical in succesfully with my xbone for DTS.

Which audio settings do you need? I haven’t really changed anything since i got it other than toggling “allow audio passthrough” on and off.

I’ll look for the video setting.

I have noticed that although it works, the optical out isn’t listed under the “audio output devices”, is this right?

Optical audio works if you select HDMI output. Optical is usually used for 5.1 passthrough. You could enable AC3 trasncoding if your device supports it, or set 5.1 channels, disable passthrough (may need to switch to a skin and enable Expert settings) and you’ll get LPCM 5.1. Check what your Samsung system reports when you have no sound.

PCM option can also be used to force analogue.

Again, it would be quite handy to have some logs and information about audio configuraton (screenshot etc).

Did you Check the DTS capable receiver in audio sertings then? Does the Vero go to the TV and from there to the samsung receiver via arc?

Because a lot of tvs won’t passthrough DTS audio.

So if it needs to go to the tv you might want to check the ac3 encode option for dts.

The receiver itself will decode DTS but only from built in player or BluRay.

A friend of mine has the same problem. So check if your TV is DTS capable if this is the case.

The Samsung all in one boxes don’t have any other input than the arc hdmi. This might make them so cheap.

Edit: Also some Samsung TVs might pass pcm audio only in 2.0 to the receiver what could cause some channels to be missing.

Best way might really be to use the on the fly ac3 encoding in kodi.

I understand the question now.

Optical audio is limited to 2.0 channels (LPCM), or 5.1 channels (DTS / AC3).

So AC3 transcoding is indeed the only possible solution if @chamelious can only connect his sound system via SPDIF and AC3 is supported. Then he would just need to enable AC3 passthrough and disable DTS.

For multi-channel PCM you need to connect via HDMI.

Sam

Update:

The Samsung all in one has Optical, not just the ARC HDMI.

What the TV with PASSTHROUGH is a tougher question to answer, although i do know it will handle DTS just fine when using its built in DLNA player.

Sounds like i will indeed just need to wait until i have a proper AV receiver i can connect to via HDMI.

Enabling AC3 transcoding should be fine for you until then, and you shouldn’t really hear the difference in audio on your current setup.

Sam

Did you try to connect the vero via optical to the receiver then?
After doing that, use passthrough for dts and ac3 (check ac3 and dts compatible receiver in kodis sound options and passthrough) and then set channels to 2.0.
Passthrough will still support up to 5.1 Channels.