Vero4K remote problem

Hi there, The remote on my Vero4K has stopped working, it has a brand new battery the blue light shows up just fine, I have a feeling it’s a problem with the dongle, I’ve done a fresh install of osmc and re paired the remote and shut the system down, still no joy.

When I plug the dongle in should it show something in Settings/System/Input/Peripherals as there is just cec adapter libcec 6.0.2 firmware v5

Should I just buy a new remote?

Thanks for the help.

If it working correctly it should show up in that screen. Posting some logs may allow us to see something. How old is this remote?

I’d say it’s 5 years or so old, I took the remote apart and cleaned it taking care of the contacts on the back of the rubber membrane, all looked fine but it still didn’t work.

In my osmc/remotes Disable RC6 is lit with a white square what’s that?

I definitely think the dongle has given out because it has always worked fine before.

The remote section in My OSMC is completely unrelated as the remote in question is an RF remote that presents itself to the OS as a regular keyboard and mouse and those settings are relating to IR remotes. The disable RC6 button forces RC5 which is generally more compatible (I think, don’t anyone quote me on that). If the dongle isn’t showing up then you would probably be looking at a remote replacement as dongles for that generation of remote are no longer available. You might want to plug the dongle into a PC and see if it is detected and working there just to be sure. You should also try to re-pair the remote as well if you haven’t tried that yet.

I have paired the dongle multiple times with no joy, I plugged the dongle into my pc and it gave a constant usb inserted noise so it’s definitely faulty.

Is there any difference with a new remote compaired to mine?
I’ll have to buy a new one off osmc.

If yours is the one with ff/rw buttons at the bottom then the new one will have volume buttons instead.