Vero4k resets resolution on every boot

Every time I boot the Vero4K it resets back to 1080p, forcing me to manually set it back to 3840 x 2160 @ 60hz every single time we want to watch a movie.

There has been several other threads on the issue and the advice has been to never power off the Vero, or to make sure all other devices are powered on first. That’s unfeasible for me.

My question is: can I hard code the output resolution somehow? Eg: force the setting to be reapplied at every boot or otherwise set it permanently?


Set Adjust refresh rate to On start/stop in Settings->Player and it will switch to 4k automatically.

Just so I understand you correctly: this will ensure the video files are output at the correct resolution for the TV? Eg. the GUI resolution and the video output resolution are unrelated settings? That’s good to know.

But is there any way to fix the GUI at the proper resolution so it behaves on my TV? (I believe the setting I’m struggling with is under System settings -> resolution, I’m not home atm to double check).

The Kodi GUI is rendered at 1080p. You will find your TV makes a better job of scaling that up to 4k than Kodi does. So there’s really no advantage in a 4k GUI.

We recommend people with 4K TV’s set their user interface (UI) to 1080p. Kodi’s UI is not optimized for 4K yet and this can put unnecessary demands on your device and can lead to a suboptimal picture quality, as well as potentially cause other issues.

The settings we recommend are as follows…

Settings>System>Display>Resolution> 1920x1080p
Settings>System>Display>Whitelist> (empty)
Settings>Player>Videos>Adjust display refresh rate> On start/stop

Some televisions may also need, or benefit from, the following being set…

System>Display>Force 4:2:2 colour subsampling> (enable)

With the above settings your UI will be output in Full HD and your 4K content will be output in 4K. If you have any doubt, feel free to upload some logs so we can verify that your settings are indeed correct.

I see. But when the GUI renders at 1080p it always overscans - the edges of the GUI are drawn beyond the physical display. I have to go into the Vero display settings and “calibrate” the output (eg. pull everything back in view). And then Vero throws the calibration away on next boot anyway.

Change the overscan/zoom setting on your display, not with the Kodi calibration, which you shouldn’t need to do with a modern display.