Video and audio stutter on file that previously layed fine (Vero 4K+)


I am getting audio and video stutter on a video file. Strange thing is that I watched a part of this video months ago and just today wanted to continue watching. It used to run fine.

File is HEVC 4k with DD audio stream
OSMC Vero 4K+ connected to a receiver (DD and DTS capable) via HDMI which is then connected to my tv. Passthrough enabled
Files on a Synology NAS, connected with gigabit ethernet (rebooted NAS and OSMC just to be sure as well)

Can’t remember changing settings but might be wrong as some time has passed. Have played many other files fine, and there were likely some OSMC updates in between viewing sessions.

Full log attached. First playing the video file (resuming), then playing another part of the documentary series from the start (to rule out a resume issue).
Both files play fine on my laptop (wifi connected where OSMC is wired)

Would need full logs (via MyOSMC) and also with Debug logging activated.

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device twice(!)

  • reproduce the issue

  • upload the log set (all configs and logs!) either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:

Thanks. Sorry had debug log on however used an addon to upload. Reran dub logging as instructed and now uploaded via OSMC menu.

What is the NAS you are using? Have you SMBv3 activated?
Alternatively try Settings -> Services -> SMB Client -> “Fix issues MTU issues with SMBv2"

1 Like

It is a Synology DS214Play. SMB3 is activated (SMB2 minimum), see screenshot
Curious, does it look like a throughput issue of some kind? These logs have so many entries.

In Kodi minimimum protocol version is “none” and Max. is SMBv3 - should I raise this minimum?

will try and test that setting later this evening,

Tried suggested setting (had to reboot). Unfortunately it still has major audio stutter.

Fix issues MTU issues with SMBv2 (now enabled)

Also disabled “audio passthrough”, doesn’t help.

Is your AVR capable of decoding TrueHD?

I noticed that you seem to have automatic library scanning turned on, and while you were watching A Perfect Planet: Volcano that the scan was running. It may be with watching the video and scanning the library that your network is being overwhelmed. Try turning off the automatic scanning and see if that helps.

1 Like

Thanks. Yes just rechecked the specs, it is a Marantz NR-1508 and listed with support for: “Dolby TrueHD and DTS-HD Master Audio”. Even so I also disabled passthrough for testing and that doesn’t help.

You are right on the library scanning, on most tries it wasn’t scanning, exactly when I was making the log it was. I was somehow under the assumption these activities are paused when playing. On all other attempts to play the file no library scanning was taking place. Even so I disabled it just to be sure however that doesn’t work.

Are there any clues in the log as to where the issue may be found? network connectivity? strange video format? video and or audio decoding issues?

Attached another log with library scanning on startup off

Update: I also have a xiaomi mi box s running kodi. It plays the file just fine. No stutter whatsoever. The mi box s is connected via WiFi.

You have your speaker setup to 2.0. I’d expect to see that as 5.1 or 7.1.

The audio in the file you are trying to play appears to be E-AC3. The audio in my copy of the same file (I ripped from disc) is Atmos. If there are multiple audio tracks do you have a correct one selected?

1 Like

Thanks. I still had 2.0 speaker setup from a while ago when I used spdif. Now all is via hdmi so thanks for spotting, changed to 4.0 which is what I currently have. Should only matter when not using passthrough?

Checked the file again, I only have one audiotrack.

Strange, perhaps I should just forget about this one and move on.

You still want to set the proper channels (4.0 if that’s your speaker setup) even when using passthrough.

If you have other Atmos or DTS-X files to test with it may help narrow down the problem. If it’s only happen on the Perfect Planet videos it may be that they are just a bad rip.

1 Like

If using an AVR, you’d always want to set the channels on Vero to 7.1 to let the AVR do all the mixing.


Thanks. I have discarded some files in the past however this one used to play and plays on laptop and Mi box s (kodi). Will try to find some more test files and discard this one.

Update: problem solved! Replaced hdmi cable between osmc and receiver and all is well again. So issue all on my side and nothing to do with osmc. Thanks to everyone for investigating.

1 Like