Video not playing after upgrade to Kodi v17

After upgrade to v17, some of the video is not playing. I have tried to re-install the Kodi v17 but still doesn’t work. The same video play with absolutely no problem in v16. I have uploaded the full log in here:

Please help!!


Provide logs after you have enabled debug logging. Also, provide mediainfo output for a problematic file.

Debug log is here:



Please, can anyone help!!

I’m having a similar issue, not sure if it’s the same. Since the update I haven’t been able to play any videos in Kodi. Music files play, but video won’t. The screen is stuck with the “Please Wait …” dialog and I need to restart the mediacenter through ssh to regain control of it.

This is the debug log for the relevant part:

Try enabling and disabling different combinations of OMXPlayer and MMAL in >Settings>Player>Videos.

Thanks. Only MMAL was enabled,and it seems that the culprit is in MMAL. If OMXPlayer is disabled and only MMAL is enabled, video won’t work. With OMXEnabled, playback works. Is MMAL supposed to work in a RPi2?

It depends on the file type you are trying to play I think.

The format of the video (rv40 - real video) is quite obscure which is why not many people are seeing this.
MMAL is the default and recommended acceleration method for Pi2 and Pi3.
But there are sometimes cases where omxplayer works better.

If you can provide a sample video I can test I can investigate further.
I have a suspicion of what it might be (ffmpeg not calling GetFormat with this codec), but would need a sample to be sure.

1 Like

In my case, this is happening with standard mp4 videos as well; basically all videos. I’m keeping both players enabled for now but I’ll keep an eye on this thread.

Yes, my problem is on real video. Other format seems working fine. But I have tried both player but still doesn’t work. Plus when I play YouTube add-on the same thing happen. Please help!!!

Provide a sample of an affected clip so @popcornmix can investigate. A Dropbox link will help.


I am preparing the sample for you to exam…

Please download the sample here:

Please let me know asap when you’ve finished downloading.



Is there any update on your investigation?

Please help, I’ve been waiting for a week now. Any update.


I am still waiting for your answer. But I also want to ask if omxplayer cannot recognize this codec, why I can play it without a problem in v16. Are you using the same player?

Any update? Please…

There are some general improvements to Raspberry Pi coming shortly and I’ll make a test build available for you.


I’m also unable to play videos on OSMC based on Krypton (things work fine in v16). I also have other issues while running OSMC on Raspberry Pi:

  • the menu is so sluggish, I cannot use it,
  • switching to original Krypton UI, setting things up, after reboot I’m switched backed to OSMC skin and my settings are lost. OSMC does not remember my skin choosed,
  • Tidal plugin stopped working with no apparent reason,
  • I reverted to v16 (glad I made a SDCard backup image). Is there a way to block upgrade to Krypton while being able to receive security updates for v16?

Does the update you mention fix the issues I mentioned above?