Video playback 'Resume' not working?

I have been using OSMC on my shiny new Pi2 for a couple of weeks. (Upgrade from a Gen1 PiB with raspbmc)
I have started to notice that ‘resume’ playback is not working (is set up to resume in Kodi settings).
I have searched for issues relating to this, and for the most part they show issues with UPNP connections.

I have a NAS that I stream from mostly. It is a SMB share though, not UPNP.

But, I have also tested video on a directly connected USB flash drive. (after having restarted the Pi), but nothing doing here too.

I believe I am supposed to see a triangle next to a file if it has a resume point stored. I do not see this (though I do see a tick to show it has been watched).

Kodi forums suggest an issue in 14.0 and 14.1. I can’t remember what version OSMC uses currently (not in the about bit of Kodi as far as I can see?). But if this was the case, there’d be more mention of it here, I’d guess.

Can anyone help?

Are you playing the videos via the Library or directly via the file browser in Videos ?

Normally, I use the file browser. I did try going through “recently added” as I read about something to do with videos inside playlist containers or something, but that didn’t work either. I could try the library link I suppose.

Last watched status is only tracked for items played through the Library.

For items you play directly from a source via Video->Files, last watch status is not tracked.

@DBMandrake, I haven’t had time to investigate whats wrong on my setup mainly for the reason that I also want to move my shared MYSQL first to OSMC before digging deeper. But actually I have a similar issue as @blueberryalpha. Since I moved to OSMC I still get the watched status updated when watching via OSMC (Library) but not when watching via Yatze streamed to my tablet. This behavior is definitely different from what I had before (have to say that when moving to OSMC I also moved from v13 to v14 so it might be related to a general Kodi change and not a OSMC issue

I can’t comment on Yatse as I don’t have any android devices to use it on, but I definitely don’t get watched status saved for files that are not in the library - I just tried it on Helix 14.2 on Windows 7 to double check. After playing half of a file and then going back to the file it just starts at the beginning again without prompting for a resume location.

Maybe it was a feature in Gotham but I don’t remember it from there either, sorry.

I’ve managed to take a look at this now.
First when I went in through library and tested, it didn’t appear to work.
However, I found a video I watched a while ago which did have a resume marker. This worked OK, and the resume point did update after playing further. Go back to other videos and behold they now work too. So not sure what all this was about (either previous resume points set before the OSMC update (which I did a few days ago).
But all appears to be working now, so that’s great.
Thanks @DBMandrake

@DBMandrake, thanks for your feedback will spend sometime after I migrated the MYSQL. Definitely something that worked in the past.