Videoplayback vanishes into background

Hi everybody,
I’m using OSMC in a keyboard/remote/mouseless installation (just as info terminal).
At some point in time (probably during the night - not every night - the videoplayback switches into background (blue OSMC desktop visible).
Having a keyboard connected I would press TAB and the video would come back. But there is no keyboard/mouse or remote control connected and in addition: Normally I’m not around this terminal.
To get rid of the situation I can stop the playback via RPC and start it again - this brings it back into foreground. But since I am not able to see if it is running in background, I would have to stop and restart it regularily (as a precaution).

Okay: to cut a long story short:

  1. is there a way to prevent that the playback goes into background
  2. if not, is there a way to tell that the video is running in background via shell command or RPC
  3. if not, is there a way to tell OSMC that it stops the video when it goes into background?

I appreciate your help.

Kind regards

It is more than likely that this is a Kodi issue or a specific Kodi function and as such you should look at addressing the issue there for best response. If you do believe that this is an OSMC specific issue, please let us know.

It sounds from your description that the screensaver is kicking in despite video being played back, do you have any add-ons installed?

Could you capture a debug log of this happening? If you can enable debug logging then reboot the device and once you notice the video has become obscured run grab-logs -A and post the resulting URL here.