Volume Amplification


I am running Kodi 4.4.3-1-osmc on an older R-Pi. This is connected to a TV using the composite video and sound jack sockets.

The sound output is very low even with TV on full volume, I used to compensate for this using the volume amplification option which worked fine but this now has no effect.

I haven’t knowingly altered anything so would appreciate any hints as to where to look.


I would say that you should either:

A. Get an HDMI Cable (audio output would be fine without amplification)

B. Do a clean install of OSMC

Try installing alsa utils and see if the pcm and all other volumes are at 100 with amixer.

Also try to turn up the volume in kodi itself.

No hdmi input, old TV.


How do you turn up the volume in Kodi?

I click the ‘sound’ icon when playing the video the set sound at maximum; that is the only way I* know.

Will try also utils.



Installed Alsa-utils but cannot see how to use it in Kodi.

On System, Settings, System, Audio Output I can change the device to Alsa but it makes no difference, the Volume Amplification makes no difference.



Look for volume up…

If that doesn’t work:
You have to use alsamixer from commandline via ssh.

Brought it up via SSH but volume controls on alsamixer make no difference at all to item being played.

Only the one sound card option so I’m not altering something that is not enabled.


So if everything is a 100 and in Kodi the volume is all the way up, too you might have a faulty cable or the pinout is not right. That could also cancel out the sound. Try another composite or 3.5 rca cable to be sure.
Is the volume loud enough when connecting headphones?

Do you have omxplayer enabled or disabled?
The algorithm for amplification is different in the two cases so might be worth trying both.

Mcobit, don’t think it can be the cables as it used to work fine, I always used to set volume amplification to around 75 then decent sound adjustable by TV remote.

Without volume amplification TV needed to be maximum and that was OK but a wee bit quiet.


Popcorn, I thought omxplayer was the only player that was successfully used on the Pi so yes, it is enabled.

Thought the disable option was only for Kodi used on something other than a Pi.


No. omxplayer is disabled by default on Pi2/Pi3. Using dvdplayer with mmal acceleration is the default/recommended setup.
On Pi1 due to the lower cpu usage we still default to omxplayer.

Annoyingly looks like I’ll have to wait for an update of Kodi and hope that resolves it.


OK thanks, I’ll look in to that one.


Hello people

Also suffering this… any resolution in sight?