Volume icon missing

Hi there,
I cannot see the volume icon since a few days now. Anyone had a similar experience?
Thanks in advance
B

PC. Actually I tried to change the audio output device from PCM to HDMI and the system crashed. Now the volume icon can be seen…
The audio output is still PCM …
Then before trying again to change it from PCM to HDMI I changed the number of channels from 5.1 to 2.0.
Then changed from PCM to HDMI. The system did not crash …

What do you mean by volume icon?
Can you show us a picture / screenshot of what you expect to see and what you see instead?

Thanks Sam
I mean the “Volume %” appearing at the top. In Kodi it is an icon.
It was gone for some time. Then, the system crashed when I tried to change the audio output from PCM to HDMI. This is something that happens often.
Now the “icon” is back.

Could you please be so kind as to post two things so we can help you find our what the actual issue is here: a debug log when reproducing the issue (can you reproduce the crashing when changing audio output?) and also a screenshot so we are sure we’re talking about the same volume level notification?

If you need any help, feel free to ask :slightly_smiling_face:

This is the volume notification I’m seeing here:

Thank you for your reply Wuschel_Wuschel. I am attaching the volume indicator that I had in mind. It is the same as what you are seeing.

As to reproducing the issue. It happens again when the PVR add-on is on. In other words when I am watching TV. If the VU+/Enigma2 Client is not on, I can change the audio without issues.

What is the best way to upload logs? I see that there is an option in the menu “Log Uploader”. Would you point to a page where I can have a look please?

1

Found the reason… Your hint with PVR was a good one: When passthrough is active you can’t change the volume :wink:

1 Like

Actually passthrough is off.
When I try to put it on, the system crashes…
Thanks

Hi @boboxjordan,

a crashing vero 4k is not a normal state.

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

In simple steps

  • activate the logging at settings -> system -> logging, (use the expert view)
  • reboot the box
  • reproduce the issue (here try to change to passthrough)
  • if you still can login via ssh, login as user osmc, password osmc and invoke grab-logs -A and tell us the URL provided
  • if you got a sad face and the mediacenter automatically restarted, use the log uploader at MyOSMC in the GUI, also provide the URL, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

Thanks @JimKnopf. That was helpful.
I enabled the debugging
Rebooted
I have the same issue of “Add-on couldnt be loaded. An unknown error has occured”. This is the PVR add-on …

Then, if I try to change PCM to HDMI and vice versa without starting the PVR client there is no crash
If I start the TV, ie. the PVR client and try to change PCM to HDMI the system crashed - sad face.
It is more or less clear that the PVR client is the issue.

This is the url

https://paste.osmc.tv/oyufuyirox

Thanks
B

Unfortunatelly, the transmitted log only contains a header line.
Please, tell us what PVR client you are using.

It might be necessary that your box should be re-installed but let’s first wait for other opinions.

The PVR is VU+/ Enigma2. It crashes every time I reboot or suspend the OSMC …