Vpnc not working after May 25 Rel

I have vpnc installed on osmc and it worked very well until the latest Release on May 25.

It does look like the tun module is not supported/loaded anymore.
/usr/sbin/vpnc: can’t open /dev/net/tun, check that it is either device char 10 200 or (with DevFS) a symlink to …/misc/net/tun (not misc/net/tun): No such device
/usr/sbin/vpnc: can’t initialise tunnel interface: No such device

I checked with modprobe tun:
> modprobe: ERROR: …/libkmod/libkmod-index.c:822 index_mm_open() magic check fail: 0 instead of b007f457

modprobe: ERROR: ../libkmod/libkmod.c:557 kmod_search_moddep() could not open moddep file '/lib/modules/4.9.29-6-osmc/modules.dep.bin'
modprobe: FATAL: Module tun not found.

Checked if i could find any modules:

find /lib/modules/ -iname ‘tun.ko.gz’
no results

Any ideas?

Could you run the following, please:

ls -l /lib/modules/4.9.29-6-osmc
grab-logs -A

After the grab-logs command, let us know the URL.

The module is probably called tun.ko, BTW.

With the release of the last night the issue could be solved.
If you think it is still usefull to provide the logs please let me know.

If the issue is resolved for you, no need for any logs.