VU+ / Enigma2 Client issue


I have been using OSMC_TGT_rbp2_20170322.img since release, it’s a basic rpi setup, USB flash disc with a few movies and the VU+ / Enigma2 Client to stream from downstairs, it was working without issue until this morning when it updated, it started looping on boot.

I downloaded OSMC_TGT_rbp2_20170504.img and tried a fresh install but I get the same error, it seems to be when it’s trying to load the VU+ / Enigma2 Client addon.

I pulled this from the log;

13:05:23.995 T:1731195888    INFO: AddOnLog: VU+ / Enigma2 Client: GetHttpXML Open webAPI with URL: ''
13:05:23.996 T:1731195888   DEBUG: CFileCache::Open - opening <web/deviceinfo> using cache
13:05:23.996 T:1731195888   DEBUG: CurlFile::Open(0x72601a80)
13:05:23.997 T:1731195888    INFO: easy_aquire - Created session to
13:05:23.998 T:1731195888   ERROR: CCurlFile::FillBuffer - Failed: Couldn't connect to server(7)
13:05:23.998 T:1731195888   ERROR: CCurlFile::Open failed with code 0 for
13:05:23.998 T:1731195888   ERROR: Open - failed to open source <>
13:05:23.998 T:1731195888   DEBUG: AddOnLog: VU+ / Enigma2 Client: GetHttpXML - Could not open webAPI.
13:05:23.998 T:1731195888   DEBUG: AddOnLog: VU+ / Enigma2 Client: Unable to parse XML: Error document empty. at line 0
13:05:23.998 T:1731195888   ERROR: AddOnLog: VU+ / Enigma2 Client: Open It seem's that the webinterface cannot be reached. Make sure that you set the correct configuration options in the addon settings!

Full version here

Here is a screenshot of me accessing the Zgemma from the same subnet

This is the output of curl from the device in question

Happy to go back to the other version but if I can help diagnose the issue and fix I’ll do that too

That magical little ‘wait for network’ in the settings resolves it…doh…!