Weather screen when I change from Vero 4k+ to TV


I own a Vero 4k+ connected directly to a Panasonic GZ960 TV, when I’m on home screen of vero, and change from Vero 4k+ to TV, the Vero goes to weather screen, how can I avoid that?

I have the CEC enabled on Vero 4k+ going into stand by state when I shutdown my TV, and I’m using an Harmony 650 controller (with Vero 4k+ profile).

I supose that it’s because a CEC command, Is it possible to disable the weather screen in vero, for avoid going into it when I change to TV? (I don’t need this screen for nothing). I’m using OSMC skin (don’t know if it’s important).


Provide debug enabled logs and reproduce the issue then we might know what causes it.

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device

  • reproduce the issue

  • upload the log set either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:


Here are the logs:


The log show F9 and being received and issuing the command to open weather. I find this rather confusing as the only thing F9 is mapped to by default is volume down. What exactly is in your ~/.kodi/userdata/keymaps/gen.xml file? If there is not something in there that is mapping the weather screen then the only thing I can think of is editing gen.xml to contain the following and rebooting to let it take effect…

<?xml version="1.0" encoding="UTF-8"?>

The content of this file was only this line:

<keymap />

I replaced with your content and the issue disappeared.



Good stuff.