Weird Video Sound Problems Over UPnP


I have OSMC running on Rapsberry Pi 3 and I’m having some really weird sound problems watching video over UPnP.

If I start watching an episode of Game of Thrones you have the first two minute intro which recaps what happened in the last episode and the sound on this part is perfectly normal. The music kicks in and that also plays fine and the episode starts and that seems to be OK until someone speaks and there is no dialogue.

I’m not saying that it is quiet, there is no dialogue at all but all other sounds are there. You can hear birds tweeting, doors opening and general background chatter but the dialogue is muted.

I’ve no idea why the beginning would be fine and the actual episode not so I tried it with an episode of Breaking Bad and it did the same thing. Intro and music fine, background noise fine but no dialogue.

This happens to both mp4 and mkv files and happens to every single file without exception. These files have never been played through the Pi before but I have watched them many times through my Samsung TV and Android devices and i know that there is nothing wrong with them.

I’ve tried playing around with the audio settings and toggling everything on and off but nothing makes any difference.

Any ideas please?


It would be good if we could find out more about the file you are having issues playing. Please see the mediainfo section in How to submit a useful support request - General - OSMC

I think I know what’s causing your problem, but I don’t know what the solution might be. For whatever reason, HBO broadcasts the recap in 2-channel stereo. So speaking voices are sent equally to the left and right channels. Once the actual new episode starts, the sound switches to 5.1 audio, and almost all of the speaking voices go to the center channel and are no longer present in the left and right channels. I don’t know what your setup actually looks like, or where you’re sourcing the TV show. However, once the new episode starts, you’re still only getting the left and right channels. So you lose the voices.

How is audio ouput from Pi?
HDMI? AV receiver? TV?

The usual cause for missing dialogue is sending 5.1 audio to a device that only supports 2.0.
True setting “number of channels” to 2.0 in system/audio settings.

It is not individual to a file it happens to all mp4 and mkv files. Files which work perfectly on every other device.

Sound goes via HDMI to Samsung TV and then via optical to Sony receiver which is capable of outputting 5.1 channels

But you described it as an issue with files that come with an intro, not all files. Do you have any files without an intro?

From my original post:

“This happens to both mp4 and mkv files and happens to every single file without exception.”

Thanks for explaining that to me, it made a lot of sense and led me to find this:

Problem solved