When I power off Raspberry Pi it just starts back up

When I power off Raspberry Pi it just starts back up, but on another tv it does shutdown correctly. Is there a way to fix this in the settings ?

Why are you even turning the pi off? It’s not designed to be turned off. Otherwise it would have a power switch… It’s not as if you are saving money, it costs $2 a year for it to idle.


Not much info to go on there… :wink:

Pi 1 or Pi 2 ? Are you shutting down via the Kodi shutdown menu or some other way ? Has it always done this or has it only recently started ?

Are you even running OSMC or are you still running Raspbmc ? I ask because rebooting when trying to shut down was a common issue on Raspbmc but I am not aware of anyone reporting this problem on OSMC.

Hello DBMandrake,

Thank you for the reply!

I am running OSMC RC2 on Pi 2. It happens if I shutdown through OSMC and through apps on my android devices ( Kore and Yatse ). What happens is when I shutdown it goes straight to start up splash screen and it’s up and running again. I did try it on another TV the exact same size and resolution and it shutdown correctly. I run my Pi 2 into an AUTO HDMI switcher which switches to the current device that is powered on. I thought this had something to do with it so I plugged it in directly but had the same problem. I also tried using my older Pi B+ with the RC2 build for it and had the same problem. I’ve been trying out every image before the release candidates and figured it was a bug that would work itself, but I never seen anyone talking about. I did come across a old post about RASPBMC with a similar problem that had to do with changing a setting but that didn’t fix problem. I run OpenElec as well on another SD card with no problems. I can’t find the related post with the fix as I tried that on RC1 some time ago when the PI2 first came out. Thanks a lot =D Here is a quick video I took with my phone


What is that screen with the diagonal line ? Do you get that on boot-up or only when you try to shut down ?

Can you edit /boot/cmdline.txt and remove the word ‘quiet’ then record a video of the shutdown again ?

It doesn’t look like it is rebooting to me, it looks like Kodi is crashing which goes back to the splash screen and then reloads Kodi. If it was a full reboot you should see the rainbow colour screen and then the OSMC splash screen.

After trying to shut down also please upload your log files using the log uploader.

Most likely you have a bad addon installed which is causing Kodi to crash on attempted exit rather than to initiate a system shutdown.


So I did a fresh install ( no ad-dons installed ) with RC3 and wanted to see if it was fixed for me now ( sorry about the month later response ).

Log File: ( was not sure which to upload so I did all of it after a failed reboot / shutdown) http://paste.osmc.io/luwiyeqipe

RC3 when it does crash on reboot or shutdown now displays this picture

When I edit /boot/cmdline.txt and removed the word ‘quiet’ just does the same thing as it was previously. Here is what I did to remove it, in case I did it wrong you could let me know =P

I did

sudo nano /boot/cmdline.txt then removed ‘quiet’.

Here is the video after I removed the ‘quiet’ ( both shutdown and restart do the same thing )


I am using a Kingston Class 10 Micro SD card
Wired Ethernet Connection
Using Yatse Remote on Android
Raspberry Pi 2