Why can I not browse my local Windows network shares?


#1

I have meant to be post about this issue for probably a year, but only just getting round to it as I use fstab mounted shares. However, this issue is still irksome when I want to manually add a mount point without reaching for my PC,

So, in a nutshell. I have SMBv2 set as my minimum SMB protocol within my NAS. Literally every other device - RHEL, Windows 10, Mac OS, iOS - in my network can browse my Samba shares. Yet despite being in the ‘browse for new share’ popup, and selecting ‘Windows network (SMB)’ I simply receive, well, nothing.

Why doesn’t this work? It used to work fine for months, then randomly just stopped. Is this expected behaviour? Surely not.


#2

Browsing is only possible with SMB1.
Did you also set the minimum Protocol on OSMC to SMB1?

Yes as SMB1 was disabled for security reasons by default on OSMC


#3

Even when using SMBv1 (both explicitly set on NAS and OSMC) my shares aren’t discoverable.

So what’s going on? They are browseable from all other clients! Just not OSMC.


#4

To be honest not sure what’s going on. Are the OSMC and NAS in same Network?

instal smbclient sudo apt-get install smbclient
and check what smbclient -L <IP of NAS> gives you.


#6

osmc@osmc:~$ smbclient -L nas
Enter osmc’s password:
protocol negotiation failed: NT_STATUS_INVALID_NETWORK_RESPONSE

However:

osmc@osmc:~$ smbclient -L nas -m smb3
Enter osmc’s password:

Sharename       Type      Comment
---------       ----      -------
ActiveBackupforBusiness Disk
Family Share    Disk
Media           Disk      Media Folder

[snip]

Works just fine.


#7

Well for me this indicates that the NAS is not running SMB1 and that the other clients not using SMB browsing but other technologies to find the shares.