Widevine add-ons stopped working from 01/09

Should have a solution for Kodi v19 soon. I have sent @joakim_s some instructions and am waiting for him to verify.

Sam

Seems to work again with your instructions. Thanks!

Wow. Thank U matthuisman, your tip seems to be functional, and it takes a few minutes to apply. Live TV, Netflix and Disney+ are working with the latest Google Widevine library. Amazon hangs however, but it’s an alpha version yet (0.9.4). There are some good developers indeed. And no, I don’t agree, Leia is not EOL yet ! After months of tests (I’ve got Kodi 19 on my Windows PC), I’m not ready to use it everyday, it hangs too much and there are too much errors notifications to use it friendly. I’ll make some tests with LibreElec when I receive my new raspberry.

I can confirm that Matt’s solution works!
I didn’t even notice that my addon stopped working - looks like I haven’t had much time to watch Netflix last week :wink:
Thanks @matthuisman , it really takes two minutes and fixes the problem :+1:

That’s odd. Amazon works perfectly fine here.

I have a solution for v19 and will push some builds to staging soon.

7 Likes

Let us know when you do, Sam. Happy to help test.

Hi everybody. I’m glad Amazon works again. I removed then installed again the plugin and go ! Problem of Widevine solved ! Now I must consider the random freezes of my Vero when stopping a video or playing with next button. It’s quite annoying to stand up for unplugging the Vero in order to start it again when it freezes and nothing answers (neither remote nor network - ssh doesnt’ answer). These freezes happened when my Vero was shipped at home, with the default installation and SPDIF toslink settings (wiki here : Audio hardware and software configuration - General - OSMC). It continues freezing after 3 different re-installations of the 3 Vero official images I’ve tested. I’ve never had these freezes with the Raspberry pi 3 + a Hihiberry DAC, SPDif Toslink and a strictly identical OSMC config.

It works wonders with 2021.08.01 release on my vero4k.

I tried Matt’s suggestion on a Pi 3B+ running the November OSMC release (Leia). The good news is that Netflix now works correctly with the latest version of Widevine, which used not to be compatible. The bad news is that neither Prime Video nor Disney+ will play anything.

@ laurent.sailla
please keep this thread on-topic.
Your freezing issue is not related to this thread, so please ask in another thread.

@ angry.sardine
Your issue is strange.
Netflix & Disney+ should still both run even with the older widevine cdm.

Go into Disney+ > add-on settings > Playback > Install Widevine CDM
Make sure it says 4.10.2252.0 is installed
And make sure you’ve done a reboot after installing / updating the widevine CDM

I expect they did.

Netflix previously wasn’t working with the 4.10.2252.0 Widevine, of course, and it now is working with it; so your patch clearly has worked at least to that extent. But, as I said, videos on Disney+ and Prime Video aren’t playing. I can launch the add on, search for something, and tell it to play, but it doesn’t actually play it.

Would debug logs tell you anything useful?

yes, debug log for Disney+ please.
If you switch back to previous widevine, do they both then work?
what version is your inputstream adaptive?

Strange in fact. If Netflix is playing, Disney+ should also. Amazon, I’ve had a problem until I remove the plugin and settings and install it again. The flow was decoded, the video stream was created but didn’t launch, without any errors in the kodi.log.

However, I’ve forgotten to say that I didn’t use November release on the Raspberry Pi 3 because I had some hangings and malfunctions (I’ve made a lot of tests). I was using the 2020.10-1 release like a charm, this release was very stable. When I get the new Raspberry, I’ll restore my fully operational personal disk image and I’ll verify I can patch it with matthuisman’s procedure and everything is ok. Perhaps I should downgrade my Vero to this release too to make it more stable.

Well, that’s disconcerting. I’d swear I haven’t changed anything since last night, but somehow Disney and Amazon are both working again this morning. Very mysterious.

Only thing I can think of is that some other add on (InputStream perhaps) has updated in the background.

Under OSMC, there are no update at all of inputstream.adaptive.
LibreElec inputstream.adaptive is more recent (2.4.8-1).
I made some tests this morning with a new RPI3 B+ and LibreElec 9.2.8 : after installation from scratch and all updates, I put my kodi backup via SSH as usual. And bingo, latest Widevine is downloaded without any problems, and everything works fine with that at first try (TV + Amazon + Disney + Netflix). The only difference is the general speed : beside the Vero, the RPI3 is awfully slow, even with all overclock settings ! What’smore (and not trivial), there’s no need of preparation for Netflix, cause LibreElec has already all libs needed : with OSMC on Vero 4k, you have to put a patch before installing Netflix, or it won’t even start (I had also forgotten this point…). I don’t remember I had to do the tip on the RPI3 with OSMC.

I’ve updated the original post with details on the status for Kodi v19.x. Test builds are now available for Vero and Raspberry Pi devices with Debian Buster.

Many thanks,

Sam

1 Like

I’m afraid mine is still not working. I updated my system with Sam’s proposed repo, then reinstalled the Widevine library, but no effect. Some relevant info here:

  • This is the NEW package that got installed with dist-upgrade:
    vero364-image-4.9.113-46-osmc:arm64

  • And these are the ones that got UPGRADED:
    libntfs-3g883 mediacenter-addon-osmc mediacenter-eventclients-common-osmc mediacenter-send-osmc mediacenter-skin-osmc ntfs-3g vero364-kernel-osmc:arm64

If all of that is correct, then I might have a problem with my Inputstream Helper configuration. Can anybody that got it working again (either with Sam’s new builds or with Matt Huisman’s solution) answer these two questions?

  • When Inputstream Helper warns you that OSMC might not support the latest Widevine CDM library and suggests you install an older version, which option did you choose?

  • What exact Widevine CDM version is working for you? You can check that in the Inputstream Helper addon (first button on the top). I’ve tried with 4.10.2252.0 (13982.88.0) and 4.10.1679.0 (13505.73.0), but none of them work in my system.

Thaks a lot!

Sam, could you please also list in the original posts which packages one is suppose to see updated (as the update is via command line, so package names should be visible this time).
Thanks.

So, do I understand correctly that if I’m on the staging repository, my Vero 4K+ should now be compatible with the latest Widevine (4.10.2252.0)?

If so, then that doesn’t seem to be happening. I’ve installed the latest Widevine version, but out of Netflix, Disney+ and Prime Video, none is currently playing video.

EDIT: Here are logs: https://paste.osmc.tv/soqumehese

(There is probably an error near the beginning where I tried to launch Netflix too soon. But once everything had loaded I went back in and tried to play something, which failed - that should be in there too, together with similar failures for Disney+ and Amazon after it.)