Wifi adapter not recognised with last OSMC version (2016.07.01)

Hi there,
I’ve bought a brand new Rapsberry Pi 3 and I have installed the last OSMC version on an SD Card.
Its working fine but I cannot connect to the wifi from home.
It is working perfectly under the Raspbian OS (from a separate SD Card) but not with OSMC.
I’ve been troubleshooting for several hours now and nothing to do, it never shows up in the wireless access points…
Also, when I’m running the command:
scan wireless
I receive the following error message:
Error /net/connman/technology/wifi: Method “Scan” with signature “” on interface “net.connman.Technology” doesn’t exist

I can’t figure out where the problem comes from.
I tried performing the following command while plugged with wired connection but no better…
sudo apt-get update
sudo apt-get dist-upgrade
sudo apt-get upgrade

Can anyone please help ?
Thank you in advance !


I’ve exactly the same problem as you. Did you get any progress on this issue?
With the August update still not working… :frowning: