WiFi adapter TP-Link WN822N v4 not recognized on Pi2

Note: This is about the 822, not 823.

When I attach my new TP-Link WN822N v4 to my Pi2 running OSMC (Linux version 4.4.27-5-osmc), it doesn’t respond by allowing me to enable WiFi, even after reboot. All it can tell me, via lsusb, is that 2357:0108 is attached.

There does appear to be a rtl8192eu driver present, and that is a match for this device, but it just isn’t working. I even added the device manually to the new_id, based on a discussion I read at libreelec.tv, but that did nothing either. (That user later reported that someone had fixed the issue for them in an update in September).

Should I send it back? Or can OSMC do what LibreELEC did?

(On a side note, I bought this based on TP-Link’s own claim that this device is supported on Linux. They say to load the driver from the CD. The “driver” on the CD is a text file that says it’s on their website. The website has no such thing, for v4. So, they lied. They get away with it because v3 does have drivers)



I have added support for you dongle and it will be included in the next version of OSMC.

Thank you for providing enough information to support your dongle.

Thanks for the lightning-fast response!

(Also, TP-Link should thank you for preventing a return.)

It’s a long story, but this device will be used by someone bedridden for the next few months at least, due to a bad surgery. This will give him something to do.


I received the January update, but unfortunately my WiFi is not working. I’m not seeing any change from the previous build, in finding the WiFi device. The device is present in the lsusb list, but no name is provided for it, and no WiFi is present either in connmanctl, or in My OSMC.

I don’t appear to have a /sys/bus/usb/drivers/rtl8192eu folder (but I think I used to…)

EDIT: To be sure the device was working, I tried it on Ubuntu on a PC, which initially did not work either. But I found advice to compile and install a driver, and that worked. I tried the same with my Pi2 with your driver, but “make” was not happy. It seems to be trying to cross compile (and I know less than I should about make files).

Maybe I can cross compile this on my Ubuntu PC, but I haven’t done that before. Can you tell me how to proceed?

(Or, I guess if there’s a package I’m missing that I should be installing…)

Are you sure your system is up to date?
You don’t need to cross compile anything, but a log might be helpful on the new system. Without that I can’t advise.

My Pi2 is up to date, as far as I can tell. dist-upgrade doesn’t install anything new.

I’ve uploaded my dmesg and kodi.log at

EDIT: I also tried this on an up-to-date OSMC on a Pi3, similarly configured, except for blacklisting of the driver for the onboard WiFi, but where I had never attempted to use this device (in case I had done something that messed it up somehow) and I have the same result. I did attach a powered USB hub in case power was the issue.

EDIT Feb 7:… uh oh. Is this a bad sign? I reinstalled OSMC from NOOBS, let it download the new update (Krypton) and it is still not recognizing the adapter.

Provide lsusb output on one of your latest installs

This is from my latest install. The 2109:2812 device is the powered USB hub. The 2357:0108 is the WN822N.

Bus 001 Device 006: ID 2109:2812  
Bus 001 Device 005: ID 2357:0108  
Bus 001 Device 004: ID 2109:2812  
Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp. SMSC9512/9514 Fast Ethernet Adapter
Bus 001 Device 002: ID 0424:9514 Standard Microsystems Corp. 
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

I’ve just fought with TP-Link’s TL-WN821N (USB id: 2357:0107) and can confirm that the driver shipped with latest osmc does not work (despite the ID present in sam’s commit above). I have compiled it myself and also no interface.
I looked at the changed file rtl8192eu-osmc/usb_intf.c at master · osmc/rtl8192eu-osmc · GitHub and just put the line

{USB_DEVICE(0x2357, 0x0107),.driver_info = RTL8192E},


#ifdef CONFIG_RTL8192E

ifdef and now it works - I have wlan0 interface and make wirelessconnection.
modinfo 8192eu shows a new alias:

alias:          usb:v2357p0107d*dc*dsc*dp*ic*isc*ip*in*

So maybe the other new IDs should be added there too?

Good spot. I should have actually seen that earlier – apologies.

This driver is only used for RTL8192EU devices, so the additional VID/PID combos were placed in the wrong area. I’ve committed the fix and will include it in the next version of OSMC.


P.S. if you can test it, much appreciated.


Many thanks! I’ll look forward to trying it out.

I received the update today, and it appears to be working well! I am able to configure the WiFi in My OSMC, and the network is working when I disconnect the wired network. (I did have some other trouble with the update, but it probably didn’t/won’t affect this.)

Great to hear

Start another post, and we’ll get it solved.