WiFi connection speed - depends on reboot

Hi guys I have a weird issue, with which I fight without success.

I have raspberry pi 2 (original power supply) with wifi dongle based on zd1211. My problem is that my max WiFi connection speed is in some days ok (1MB/s) and sometimes not (50-100kB/s). What I checked:

  • reinstallation of OSMC - nothing changed
  • replacement of power supply (before I had a chinese one) - nothing changed
  • other router - nothing changed
  • reboot / plug in to other USB port - sometimes helps, but only for few days

For me it looks like Pi is not giving enough power on USB port, so dongle is not working on full capacity. Is there any chance to check that, or force Pi to give max power on USB ports?

Of course on ethernet there is no issue, but I have no possibility to make such connection permanent (rented flat, ethernet socket in another room).

There is an option to set max_usb_current = 1 under the Rasperry Pi settings (accessible through MyOSMC). The allows a current of up to 1.2 A through the usb ports, rather than default 600 mA.

“The Raspberry Pi model B+ and 2B can supply 600mA/1.2A to downstream USB peripherals, switchable by a firmware setting.”

1 Like

Forgot to mention, I enabled this option, but issue still exist. Also I have connected to Pi only this dongle and hdmi cable, other USB ports are unused.

have you tried connecting the adapter using a (powered) usb hub?

Have you tried the obvious wifi related checks, such as moving the device closer to the router to see if it is weak signal (how far away is it ?) and switching the channel of the router in case there is interference on the channel you are on ?

No, I will get one and try it there is no other option

Yes I checked that, but it doesn’t look like there is an issue. If I take it closer it does not work better (same for other channels). It just for no reason starts to work around 10x slower (no other device is using connection in this time, checked)

BINGO! :slight_smile: it works perfectly with active hub, thanks for help.

Glad it’s working now! I am a little surprised, though. I did not think a WiFi adapter would be a huge current draw. I have one plugged into my RPi all the time with no trouble.

Out of interest, what kind of power supply are you using for the Pi (you said you replaced it, but did not give specs on the new one)?

Did you ever see the low voltage warning on the output display (rainbow square in corner)? Do you have anything else plugged into the USB ports or GPIO pins?

Some wifi adaptors draw a surprisingly high amount of current. I have one in particular that I can’t power off my Pi 2 at the same time as an external hard drive, but the other 3 I have I can. It also gets pretty hot when in use.

  • old power supply - some chinese one, declared 5V 2A - but here I had sometimes low voltage warnings
  • new power supply - same parameters 5V 2A - but here I had never seen this warning - it is this one online shop (page is in polish, but I am sure that all details should be clear for you :wink: )

As for other devices connected to raspberry I have:

  • HDMI cable to my TV - permanently connected
  • pendrive - occasionally connected - but issue was appearing even when this one was not connected.

Thanks! I’ve a Sitecom WL352, and before setting max_usb_current to 1 the wifi speed crawled. After, it flew.