Wifi dongle driver support

hi guys I bought a 5ghz wifi dongle off ebay the drivers on the disk are mt 7610u for media tek but there are also rtl8192xc drivers on there I want to be able to use the 5ghz for osmc has a driver been compiled for this yet as I cant seem to get it to work thanks ?

The two drivers are for two different chipsets. It is possible the eBay seller include both because the chipset in the dongle is not always the same

Either way – both drivers are included in the July version of OSMC. I recommend you upgrade over wired Ethernet then set up WiFi after that


hi sam ive done what you said update over ethernet but when I plug the dongle into usb port no light appears on it I tried lsusb and the dongle shows up in it looked in networks in settings and no wireless appears any more ideas as what it could be thanks ?

Can you post output of dmesg and lsusb?


@sam_nazarko hi sam thanks for your reply I thought id do a fresh install to see if that would make any difference in getting the dongle to work no such luck I’m afraid :confused: how do I output the logs for just dmesg and lsusb instead of uploading all logs is there any way of installing the driver manually although this is beyond my capability many thanks

dmesg | paste-log
lsusb | paste-log


@sam_nazarko thanks for reply sam really appreciated I will do it as soon as I get home from work thanks

@sam_nazarko hi sam here are the logs u asked for the 5ghz dongle in question is a mediatec mt7610 http://paste.osmc.io/calukodidu and http://paste.osmc.io/eretadazom the first one is the dmesg it says on your blog that support for the dongle or chipset has been supported in the latest update but nothing in wireless setting when I plug it in I know it works because I tried it on my laptop hope this helps you many thanks again for your time also is there a way load the device manually ???