Wifi dongle Issues while booting


Hope someone can help with this, I seem to have an issue with my new wifi dongle.
Every-time I boot with it connected I get the following error come up, just after the splash screen appears, and everything freezes, no ssh etc.

Here the strange bit, if I wait until osmc has fully loaded kodi and plug the dongle in everything works fine.

Current setup is
Rpi2 running a fresh install of January build.(have tried latest build with same problems)
I have a 4 port hub connected with 3 hard drives, and a standard mce remote connected.
I don’t have much info on the wifi dongle, but its this one.


Any help is appreciated.

Thanks and Regards


another screenshot.

The dongle is likely faulty – does it work on another computer?

Hard to work out what’s going on without chipset information

It does seem to work fine on other devices like PC, also work well with osmc, but only if plugged after its booted.

on the pc it shows as realtek RTL8192EU, hope this helps.

Also this might be relevant, when doing a clean install, with the dongle plugged in, everything installs and boots to osmc fine, this problem happens from the 2nd boot onwards.
Basically the 1st boot is fine, any restarts after 1st boot cause this problem.

1st boot is fine because there are no WiFi drivers in the installer.

RTL8192EU is supported by OSMC, but there may be an overlapping VID/PID that loads another, incompatible module which causes the panic. It’s hard to say without the dongle details.

Easiest method may be to return it and get a different one.

Did you try using usb_max_current=1 in your /boot/config.txt ?

OK, took it back to the shop and the guy said there’s nothing wrong with it, but still changed it for a new one.
Got home and still have the same problem, also max usb did nothing.

Tried a different sd card with openelec and not getting this problem, works fine, but I don’t like openelec.

Anyway thanks for your help, its not really a problem, Ill just plug it in after the pis booted.

Quick update, upgraded to latest versions of osmc today and all these problems have gone, boots fine with everything plugged in.
Got a couple of pvr problems now, but will start a new thread.