Windows 10 machine can't access Vero 4k via SMB

Have seen many SMB related posts, sorry to add to the lot as I didn’t quite see what I could do.,

Have multiple HDD and enclosures attached to the Vero via USB Hub.
I can FTP into them from my Windows machine to transfer files but cannot access the Vero (which does show up as OSMC in my network.

When trying to access that it gives Network Error - Windows cannot access \OSMC

SMB enabled at Vero and set to Maximum version.
SMB for all versions is enabled via Windows features on the PC.

I have seen that starting and stopping SMB on the Vero might help, but I can’t find that post anymore to try it.

Also I have seen many posts similar to this related to fstab but don’t know if that is relevant here and with 9 drives, having read the fstab posts seems like maybe more than I require.


Did you set SMB version in Kodi or smb.conf on the Vero?

In Kodi, via Settings–>Services–>SMB Client - Maximum set to SMBv3

smb.conf contents:


    config file = /etc/samba/smb-local.conf

    workgroup = WORKGROUP
    follow symlinks = yes
    wide links = no
    unix extensions = no
    lock directory = /var/cache/samba
    load printers = no
    printing = bsd
    printcap name = /dev/null
    disable spoolss = yes
    log level = 1
    map to guest = bad user
#   usershare template share = automount template

    read raw = Yes
    write raw = Yes
    strict locking = no
    min receivefile size = 16384
    use sendfile = true
    aio read size = 2048
    aio write size = 2048
    socket options = TCP_NODELAY IPTOS_LOWDELAY SO_RCVBUF=131072 SO_SNDBUF=131072

    browsable = yes
    read only = no
    valid users = osmc
    path = /home/osmc
    comment = OSMC Home Directory

[automount template]
    browseable = yes
    -valid = no
    valid users = osmc
    path = %P
    hide files = /$RECYCLE.BIN/System Volume Information/desktop.ini/thumbs.db/

include = /etc/samba/smb-shares.conf

Edit smb.conf

Under the [global] section and append the following line:
min protocol = SMB2
Save and then restart samba:

systemctl restart smbd

Thanks, feel like I’m missing a setup piece since I can sftp into the box, find the smb.conf and open it, but won’t me save changes, says permission denied.

You have to use ssh instead because it needs root access to edit that file.

Details regarding how to access the command line interface can be found here on our Wiki: Accessing the command line - General - OSMC

Ssh (use the latest putty) in to your vero and

sudo nano /etc/samba/smb.conf

Thanks, did that, edited the file to add the line, saved and confirmed the change, ran the restart smbd and also rebooted the Vero - no change on the Windows PC.
OSMC shows up in my Network window, but when I try to access it, says permission denied.

Thanks for the tips! I still have access via sftp so that’ll have to do for now I suppose.

Just a thought, could it be that you have bad credentials stored in you windows computer trying to access osmc device?

How to remove saved network credentials on Windows 10

That’s an interesting one, but since this is a new install (from Win 7 where this all worked last month) I have yet to successfully hit the Vero shares. So using that Credential Manager shows nothing, really great idea though, I would not have thought about that one.

After another reboot now OSMC doesn’t even appear in NETWORK, but I can still connect via SSH and WinSCP, I can even ping it from a cmd prompt. The vero and the PC are in the same group WORKGROUP (original I know)
Must be a Windows setting somewhere I missed.

Try this in explorers address bar:



\\ “ip of your OSMC device” \osmc

without the “”

You did install smb server package from my osmc - app store right? Default is only client.

Yes, Samba server installed. This worked on the same PC when it had Win 7 on it last month.
I replaced the hard drive and put a fresh Win 10 on it, so the issue I’m guessing is Windows.

And Joakim, neither of those work in Explorer address bar “Windows cannot access…”

I suggest to start checking event manager on windows to check for errors. Next step after that is start Samba with debugging.