Windows cannot see 2nd HDD connected to Pi

Bit of a weird one that I cannot work out

I run OSMC on a Pi3 as a media player and had two USB HDDs connected. I have a tablet also running OSMC that could browse the HDDs, and was able to get to both HDDs from my Windows 10 PC. All well and good.

One of my HDDs got full (call it Drive1), so I bought a bigger one (Drive3), copied over all the data, hooked it up - all running as before.

But while sorting out all the data, I renamed the other HDD (Drive2). Drive2 is working fine in OSMC on the Pi, and I can access it on the tablet, but my PC can’t see the drive despite previously being able to. Drive3 is working fine across all three.

I’ve tried reinstalling Samba, mapping to Drive2 using the old name and the new name, and rebooting all three devices. Searched high and wide across the internet but can’t find an answer.

Anyone got any suggestions on what to try? Ideas would be appreciated!

Pi is Q1 2018, 3 Model B+, PCB Revision 1.3, Memory 1 GB
OSMC running Kodi 18.7, compiled: 2020-06-03

First step provide logs either via MyOSMC or grab-logs -A and share the URL.

Ok, your logs telling us currently 2 drives connected

sda = a 10TB drive mounted as /media/Media Drive which you would see under samba as Media Drive. This drive has 2 partitions where the 2nd partition is the one mounted under /media/Media Drive as spaces in directory and drive names can give quite some headaches I suggest you change the label of that drive to MediaDrive which already may solve your issues

sdb = a 3TB drive mounted as /media/Backup nothing special about that drive and you should see it under samba as Backup.

Please let me know which drive you don’t see and if changing the label/name of the drive to take out the space helps to solve your issue.

Media Drive is the one that’s working fine across all three devices (Pi, tablet, PC).

Backup is the drive I can’t see in Windows. Working fine on the Pi and tablet.

What do you define as “see”. What happens if you enter in explorer \\<IP of OSMC>\Backup?

Dialog box "Windows cannot access \\osmc\Backup (or \\\Backup)

open cmd and run net view \\
and show the output you also can try
net use * /del and then net use \\\Backup /user:osmc

First command output

Shared resources at \\

Samba 4.5.16-Debian

Share name   Type  Used as  Comment

Media Drive  Disk           Auto-mount Volume
osmc         Disk           OSMC Home Directory
The command completed successfully.

Second command output (used default password for osmc, which works to gain SSH access to the Pi)

Enter the password for 'osmc' to connect to '':
System error 53 has occurred.

The network path was not found.

Ok so Backup is missing, there might be an issue we the label being “occupied” can you try to change Label of the disk from Backup to e.g. Backup_3TB and see if you then can connect.

1 Like

Renamed Backup back to it’s original name and rebooted the Pi. Went back to the PC and it connected to it straight away.

Seems something didn’t like the drive being called Backup?

Thanks very much for your help, greatly appreciated!

Yeah I saw this in the logs and that made ask you to change it. Could be a system reserved name.
Oct 23 15:39:11 osmc udisks-glue[383]: net usershare add: share name backup is already a valid system user name