Wired LAN not working

Hello, wanna ask if someone ran into similar problem.
I bought Vero 4k and used it just with wifi - working okay.
Today I wanted to connect via wired LAN and it can’t negotiate DHCP lease with router. In OSMC and in ifconfig (SSH) I can see IP 169.254.xxx.xxx, which is not good.

I have Mikrotik RB951G-2HnD router. In the log and in DHCP view in router I can see how it offer lease to particular IP, but after a while it ends with statement that lease was without success.
To the same LAN cable was before connected my old HTPC, and it worked okay.

I have Vero 4k connected to the same router via wifi and it works okay, I just wanna wired connection because of faster speed (router have only 2.4Ghz)

I tried:

  • different LAN patch cable
  • wired config via DHCP or static IP
  • restart router
  • restart Vero 4k (few times, also with disabled wifi and bluetooth)
  • restrict LAN port speed on router to 100Mbit

The problem still remains. Is there something else we can try?

Goto MyOSMC->Networks and check whether WIRED is enabled and WIRELESS is disabled.

Does setting a static IP as a quick test help?
Try a different Ethernet cable / port


Thx for suggestions, I have did some tests yesterday.

My LAN looks like this:
FTTH optic → Huawei HG8245H optic/metallic converter and wifi router → Mikrotik RB951G-2HnD wifi router → PC via cable , iPhone, iPad, Samsung Smart TV, Vero4k via wifi

Disabled everything except wired LAN on Vero 4k.
Even when I restarted Vero or router, the problem remains.
Also with static IP in Vero, problem still remains.

When I tried to connect Vero in different router ports, weird thing happened. Router was trying to offer DHCP lease only in port 3. In ports 4 and 5, it sees connected Vero, even pair its MAC with static IP (if set in Vero), but in case with DHCP use it will not offering IP.

While browsing Mikrotik forums regarding " DHCP offered lease without success" message, I found one issue, which many of people experienced too. If interested, you can read about it here:

There was few solutions, so I tried it:

  1. set Admin MAC on Bridge setting in router
  2. disable RTSP on Bridge setting in router
  3. disable BOOTP support in DHCP server setting in router
  4. set DHCP Authoritative setting to “after2s delay” in DHCP server setting in router

Tried to set/ disable those things, but even after another restarts of Vero and router, problem still remains.

Then I tried to connect laptop with Windows 7 to the same cable, where Vero have problems - it worked flawlessly, immediatelly got IP from DHCP, internet was running also.

In the end, I have completely reset Mikrotik router, update its system to latest version and do all settings again from scratch. Who have Mikrotik knows, that it is not trivial task :slight_smile:
I have also did a clean reinstall of Vero 4k from usb stick, following guide on OSMC website, created usb stick with installer, etc. Then I set everything back up.

…aaaand problem still remains.

So far, I can’t clearly tell, where the problem is. It points once to Vero, once to Mikrotik. By resetting router to default and reinstall Vero, I think we eliminated at least software errors.

Now, I got one more idea to try:
I will try to connect Vero directly to that Huawei HG8245H optical converter/wifi router, which is in front of Mikrotik. It offering IP by DHCP too, although in another subnet, but I can log in and see if Vero get its IP address and connect to internet.
This can tell us almost surely, if the problem is in Vero, in Mikrotik, or if they both simply dont like each other :slight_smile:
Will test it today’s evening.

Is there also any mean through which I can diagnose this from Vero 4k? I heard something about Connman.

So, I have tried to connect Vero 4k directly to that Huawei HG8245H router and it worked. Vero got IP from its DHCP and working okay.

In the end it just seems, that Vero 4k and my Mikrotik RB951G-2HnD router just dont like each other :slight_smile: God knows why.

Hope this helps anyone in the future with similar problems.

You could try the latest Ethernet improvements if you’re interested.

I’d appreciate it if you could test this and provide feedback before we potentially release this as an update to other users. To test this update:

  1. Login via the command line
  2. Edit the file /etc/apt/sources.list
  3. Add the following line: deb http://apt.osmc.tv stretch-devel main
  4. Run the following commands to update: sudo apt-get update && sudo apt-get dist-upgrade && reboot
  5. Your system should have have received the update.

Please see if the issue is resolved.

I also recommend you edit /etc/apt/sources.list again and remove the line that you added after updating. This will return you to the normal update channel.

Will test it :slight_smile:

Ok, I have done that update. Edited sources.list, ran command. Everything went OK.
Vero still not connect to mikrotik, problem remain the same with DHCP or static IP.

With static IP set, I tried to restart Vero via Kodi. And now, I do not have wired connection at all.
In My OSMC it says “no wired connection” regardless if I enable or disable Adapter.
Another two restarts didnt help.

On my both routers, Mikrotik or Huawei it now even dont detect connected cable, like it is not connected. The LAN in Vero is now completely dead.

What we can do now? I hope it didnt died, I want it to work with Huawei router at least…

Here is ifconfig from vero, while logged in locally:
Tried also sudo ifconfig eth0 up - it did nothing

UPDATE: I have to do complete OSMC reinstall from USB on Vero 4k. After reinstall, wired LAN working again.

Maybe there’s a typo in the static config? Being logged in locally

What is the output of

sudo ip addr

To reset the ethernet config try

sudo rm -R /var/lib/connman/ethernet_* && sudo reboot

Could you explain your network architecture in more depth?
You have two routers and both are DHCP servers. Although they offer different subnets how do you guarantee that a client get a DHCP lease from router A and not B and vice versa?

Static IP was correct, checked it.

My LAN looks like this:
FTTH optic → Huawei HG8245H optic/metallic converter and wifi router (192.168.100.xxx) → Mikrotik RB951G-2HnD wifi router (NAT to subnet 192.168.0.xxx)-> PC via cable , iPhone, iPad, Samsung Smart TV, Vero4k via wifi

I must have Huawei there, because of my FTTH ISP (Orange fibernet) and its converting optic to metallic cable. Mikrotik is connected to its LAN1, it obtains IP from Huawei’s DHCP to serve internet.

I am ensuring to use correct DHCP server from particular router by connecting the device right into it.
Regarding DHCP, the routers are isolated, each of them have different subnet.

On the other side, I think if there was any two DHCP server conflict, also any other devices would have problems. But problems are just with Vero when using wired interface. When using wifi - no problems.

Thanks for all advices, but that sudden death of wired LAN port as scared me. Luckily, reinstall of OSMC solved it. I have even thought that it is dead for good, and it will be needed to send Vero for RMA, so no movies or tv series for a week or two. My wife, who is huge TV series maniac, will kill me. You know it :slight_smile:
Sadly, I also dont have time to set up everything over and over again, if something like this can happen.

Really dont know what happened. I have just set static IP and restart Vero. After restart, wired LAN port was dead completely.

Vero is working when connected into Huawei, I can access it in my LAN and it have internet access. I can use it like this with no problem. As I know so far, I am probably only one with this problem.
This problem with Mikrotik seems to be more complicated as it looks.

1 Like