Wireless dongle once worked until we switched providers

http://paste.ubuntu.com/12145325/

hey guys, I switched from verizon to optimum and I changed the SSID and the password. I tried to update and reboot but I am getting the exception above. Would anyone be able to help identify why it looks like this?

Thanks in advance.

This forum is for OSMC. You are still using Raspbmc. Raspbmc is a legacy and unsupported product. Please see osmc.tv/download and upgrade to the latest version

Sam

Hey Sam, Thank you for replying. However, I have a ton of pis in various locations all running the same OS level. I know its before OSMC, I was actually actively watching this forum when it first came out, but I can’t upgrade yet. I went to get support on raspbmc forums, but its read only and I was directed to the OSMC forum. So I realize its older, and maybe unsupported, but I know that someone knows whats up with the exception. It seems to think the SSID is “None”. However, I have set it. Would you happen to know why it is giving that exception and how I could go around it? Could I just upgrade the network manager? Any help without me having to reinstall/ upgrade the OS level would be appreciated. I will ipgrade/compile packages if I have too. Thanks in advance,
Chris

Ok I fixed it. So ill post what I fixed in case any one stumbles upon this from google. So raspbmc’s settings just wouldn’t take any settings. So I ran a “nmcli c” and checked the /home/pi/.kodi/userdata/addon_data/script.raspbmc.settings/settings.xml script to make sure the uuid of the device matched my wireless adapter. That fixed my “exception” error. However, I still could not get my wireless adapter up and running. So I bypassed raspbmc and edited the interface files myself. NOTE: I created both these files and placed the following in therm. Here is one file that defines my wlan0 configuration:
pi@GeorgePiNJ:~$ cat /etc/network/interfaces

allow-hotplug wlan0
auto wlan0
iface wlan0 inet dhcp
wpa-ssid “wifi_name”
wpa-psk “password”
wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf

And here is the other:

pi@GeorgePiNJ:~$ cat /etc/wpa_supplicant/wpa_supplicant.conf
ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1

network={
ssid=“wifi_name”
psk=“password”
proto=RSN
key_mgmt=WPA-PSK
pairwise=CCMP
auth_alg=OPEN
}
After this, I ran a “sudo ifup wlan0” and I watched the magic happen. I also rebooted it and all was fine. My ssh just stopped working, so I had to renable it to start on boot:
sudo update-rc.d ssh defaults
Now everything is perfect. Hope that helps someone.